aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Cwd
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-10-12 17:21:54 +0800
committermiwi <miwi@FreeBSD.org>2008-10-12 17:21:54 +0800
commit1387302498ce5104bfd17462d00b9ee1c7df8602 (patch)
treeae1595225956e6c714405f92d8799497fd26a2f6 /devel/p5-Cwd
parent42a870d6a0b9c1d1b19fbcd94fac07f9489a004e (diff)
downloadfreebsd-ports-gnome-1387302498ce5104bfd17462d00b9ee1c7df8602.tar.gz
freebsd-ports-gnome-1387302498ce5104bfd17462d00b9ee1c7df8602.tar.zst
freebsd-ports-gnome-1387302498ce5104bfd17462d00b9ee1c7df8602.zip
Cwd - get pathname of current working directory
This module provides functions for determining the pathname of the current working directory. It is recommended that getcwd (or another *cwd() function) be used in all code to ensure portability. By default, it exports the functions cwd(), getcwd(), fastcwd(), and fastgetcwd() (and, on Win32, getdcwd()) into the caller's namespace. WWW: http://search.cpan.org/~kwilliams/Cwd-2.21/Cwd.pm PR: ports/127881 Submitted by: Dennis Herrmann <adox at mcx2.org>
Diffstat (limited to 'devel/p5-Cwd')
-rw-r--r--devel/p5-Cwd/Makefile21
-rw-r--r--devel/p5-Cwd/distinfo3
-rw-r--r--devel/p5-Cwd/pkg-descr10
-rw-r--r--devel/p5-Cwd/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-Cwd/Makefile b/devel/p5-Cwd/Makefile
new file mode 100644
index 000000000000..c1d679038a5c
--- /dev/null
+++ b/devel/p5-Cwd/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Audio-Mixer
+# Date created: 06 Oct 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cwd
+PORTVERSION= 2.21
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adox@mcx2.org
+COMMENT= Get pathname of current working directory
+
+PERL_CONFIGURE= YES
+
+MAN3= Cwd.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Cwd/distinfo b/devel/p5-Cwd/distinfo
new file mode 100644
index 000000000000..10cab90fce72
--- /dev/null
+++ b/devel/p5-Cwd/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cwd-2.21.tar.gz) = 030eeaa1957726b5e32d0eaada9c7bf6
+SHA256 (Cwd-2.21.tar.gz) = 103ce2613776ea6a7bf1ab580fbbdad20a09e3ccd48a001a32c59e3d95b30260
+SIZE (Cwd-2.21.tar.gz) = 16223
diff --git a/devel/p5-Cwd/pkg-descr b/devel/p5-Cwd/pkg-descr
new file mode 100644
index 000000000000..7a7b5f408607
--- /dev/null
+++ b/devel/p5-Cwd/pkg-descr
@@ -0,0 +1,10 @@
+Cwd - get pathname of current working directory
+
+This module provides functions for determining the pathname of the current
+working directory. It is recommended that getcwd (or another *cwd() function)
+be used in all code to ensure portability.
+
+By default, it exports the functions cwd(), getcwd(), fastcwd(), and
+fastgetcwd() (and, on Win32, getdcwd()) into the caller's namespace.
+
+WWW: http://search.cpan.org/~kwilliams/Cwd-2.21/Cwd.pm
diff --git a/devel/p5-Cwd/pkg-plist b/devel/p5-Cwd/pkg-plist
new file mode 100644
index 000000000000..0122aa064e4a
--- /dev/null
+++ b/devel/p5-Cwd/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Cwd.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd/Cwd.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd/Cwd.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd