aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-DateTime
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /devel/p5-DateTime
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'devel/p5-DateTime')
-rw-r--r--devel/p5-DateTime/Makefile3
-rw-r--r--devel/p5-DateTime/pkg-plist16
2 files changed, 10 insertions, 9 deletions
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
index ca6c2ddc5bfe..9637a41fa52e 100644
--- a/devel/p5-DateTime/Makefile
+++ b/devel/p5-DateTime/Makefile
@@ -3,6 +3,7 @@
PORTNAME= DateTime
PORTVERSION= 1.12
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:DROLSKY
@@ -29,7 +30,7 @@ USE_PERL5= modbuild
PORTDOCS= CREDITS Changes TODO
post-install:
- @${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/DateTime/DateTime.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DateTime/DateTime.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
diff --git a/devel/p5-DateTime/pkg-plist b/devel/p5-DateTime/pkg-plist
index 775909c2d564..08e1d19b37fd 100644
--- a/devel/p5-DateTime/pkg-plist
+++ b/devel/p5-DateTime/pkg-plist
@@ -2,11 +2,11 @@
%%PERL5_MAN3%%/DateTime::Duration.3.gz
%%PERL5_MAN3%%/DateTime::Infinite.3.gz
%%PERL5_MAN3%%/DateTime::LeapSecond.3.gz
-%%SITE_PERL%%/%%PERL_ARCH%%/DateTime.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Duration.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Helpers.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Infinite.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/LeapSecond.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DateTimePP.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DateTimePPExtra.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/DateTime.so
+%%SITE_ARCH%%/DateTime.pm
+%%SITE_ARCH%%/DateTime/Duration.pm
+%%SITE_ARCH%%/DateTime/Helpers.pm
+%%SITE_ARCH%%/DateTime/Infinite.pm
+%%SITE_ARCH%%/DateTime/LeapSecond.pm
+%%SITE_ARCH%%/DateTimePP.pm
+%%SITE_ARCH%%/DateTimePPExtra.pm
+%%SITE_ARCH%%/auto/DateTime/DateTime.so