aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Dir-Project
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-07-15 05:21:22 +0800
committererwin <erwin@FreeBSD.org>2006-07-15 05:21:22 +0800
commitf9bf6004d9556ca9828bed126f86f2e0f654f44f (patch)
tree1aa435121c344ddb5c685d84a1063f7c31d8a788 /devel/p5-Dir-Project
parente0b7300b78c65cdd1556ddfe7d75d2a85b2059b8 (diff)
downloadfreebsd-ports-gnome-f9bf6004d9556ca9828bed126f86f2e0f654f44f.tar.gz
freebsd-ports-gnome-f9bf6004d9556ca9828bed126f86f2e0f654f44f.tar.zst
freebsd-ports-gnome-f9bf6004d9556ca9828bed126f86f2e0f654f44f.zip
Dir::Project provides a way to locate a source-controlled directory
(CVS, Subversion, Perforce, etc) using only the current working directory (cd). This prevents users from having to set other environment variables when they switch between areas, and allows scripts and such inside the directory to be executed without changing the user's PATH. WWW: http://search.cpan.org/dist/Dir-Project/ PR: ports/100307 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel/p5-Dir-Project')
-rw-r--r--devel/p5-Dir-Project/Makefile24
-rw-r--r--devel/p5-Dir-Project/distinfo3
-rw-r--r--devel/p5-Dir-Project/pkg-descr8
-rw-r--r--devel/p5-Dir-Project/pkg-plist9
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Dir-Project/Makefile b/devel/p5-Dir-Project/Makefile
new file mode 100644
index 000000000000..af99cd1298a6
--- /dev/null
+++ b/devel/p5-Dir-Project/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Dir-Project
+# Date created: 2006-07-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dir-Project
+PORTVERSION= 3.000
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Dir
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Project Environment determination
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV+= DIRPROJECT_PREFIX=${PREFIX}
+
+MAN1= project_bin.1 project_dir.1
+MAN3= Dir::Project.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Dir-Project/distinfo b/devel/p5-Dir-Project/distinfo
new file mode 100644
index 000000000000..dd7ee3f3b11e
--- /dev/null
+++ b/devel/p5-Dir-Project/distinfo
@@ -0,0 +1,3 @@
+MD5 (Dir-Project-3.000.tar.gz) = a4e0d30b3a3502a5e3708f305314a5c7
+SHA256 (Dir-Project-3.000.tar.gz) = 2e9a41063623260aff41a5cfba4c61612ec484ead5c35575e6545c5532dc6e53
+SIZE (Dir-Project-3.000.tar.gz) = 9842
diff --git a/devel/p5-Dir-Project/pkg-descr b/devel/p5-Dir-Project/pkg-descr
new file mode 100644
index 000000000000..e82b0c480051
--- /dev/null
+++ b/devel/p5-Dir-Project/pkg-descr
@@ -0,0 +1,8 @@
+Dir::Project provides a way to locate a source-controlled directory
+(CVS, Subversion, Perforce, etc) using only the current working
+directory (cd). This prevents users from having to set other
+environment variables when they switch between areas, and allows
+scripts and such inside the directory to be executed without changing
+the user's PATH.
+
+WWW: http://search.cpan.org/dist/Dir-Project/
diff --git a/devel/p5-Dir-Project/pkg-plist b/devel/p5-Dir-Project/pkg-plist
new file mode 100644
index 000000000000..9716c81bf1a2
--- /dev/null
+++ b/devel/p5-Dir-Project/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+bin/project_bin
+bin/project_dir
+lib/project_dir.mk
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dir/Project/.packlist
+%%SITE_PERL%%/Dir/Project.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dir/Project
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dir
+@dirrmtry %%SITE_PERL%%/Dir