aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-IPC-Mmap
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-15 13:37:29 +0800
committerclsung <clsung@FreeBSD.org>2006-07-15 13:37:29 +0800
commit600c342535fcd191f262b52d22ecc5ab1b21e21f (patch)
tree512cf47f58d79bba692876c9dcc47c6cd2e5074b /devel/p5-IPC-Mmap
parentcb71cec0d8493874b743d30d84b98818a792518b (diff)
downloadfreebsd-ports-gnome-600c342535fcd191f262b52d22ecc5ab1b21e21f.tar.gz
freebsd-ports-gnome-600c342535fcd191f262b52d22ecc5ab1b21e21f.tar.zst
freebsd-ports-gnome-600c342535fcd191f262b52d22ecc5ab1b21e21f.zip
Add p5-IPC-Mmap 0.11, provides a minimal mmap() interface for both POSIX
and Win32. PR: ports/100256 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel/p5-IPC-Mmap')
-rw-r--r--devel/p5-IPC-Mmap/Makefile28
-rw-r--r--devel/p5-IPC-Mmap/distinfo3
-rw-r--r--devel/p5-IPC-Mmap/pkg-descr19
-rw-r--r--devel/p5-IPC-Mmap/pkg-plist12
4 files changed, 62 insertions, 0 deletions
diff --git a/devel/p5-IPC-Mmap/Makefile b/devel/p5-IPC-Mmap/Makefile
new file mode 100644
index 000000000000..1a70f8ad2228
--- /dev/null
+++ b/devel/p5-IPC-Mmap/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-IPC-Mmap
+# Date created: 2006-07-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-Mmap
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Provides a minimal mmap() interface for both POSIX and Win32
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::Mmap.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IPC-Mmap/distinfo b/devel/p5-IPC-Mmap/distinfo
new file mode 100644
index 000000000000..9157c89b30f8
--- /dev/null
+++ b/devel/p5-IPC-Mmap/distinfo
@@ -0,0 +1,3 @@
+MD5 (IPC-Mmap-0.11.tar.gz) = 8d63fa396234d6989e9506b13ccb269b
+SHA256 (IPC-Mmap-0.11.tar.gz) = ede1b97e75571da13c6ec7f414a92d8f8797aa47744212cd677219a11b63da8f
+SIZE (IPC-Mmap-0.11.tar.gz) = 18298
diff --git a/devel/p5-IPC-Mmap/pkg-descr b/devel/p5-IPC-Mmap/pkg-descr
new file mode 100644
index 000000000000..f3baea7d290c
--- /dev/null
+++ b/devel/p5-IPC-Mmap/pkg-descr
@@ -0,0 +1,19 @@
+Provides an object-oriented interface to either the POSIX mmap() or
+Win32 equivalent APIs to memory map a file into a process's address
+space for general memory access. IPC::Mmap provides only a minimal
+interface without the additional overhead of tie'd variables or
+locking enforced in other modules (e.g., Sys::Mmap, Win32::MMF); hence,
+the application is responsible for performing read()'s and write()'s
+on the IPC::Mmap object, and calling any needed lock() and unlock()
+methods, as required by concurrent processes.
+
+Memory mapped files provide an alternate shared memory mechanism for
+multiple processes. The technique maps the OS's file system buffers
+for a given file into each mmap()'ing process's virtual memory space,
+thereby permitting each process to essentially share the same physical
+memory. Refer to the excellent "Advanced Programming in the UNIX
+Environment", Stevens et al., Addison-Wesley Publisher for a detailed
+reference on the POSIX implementation. IPC::Mmap provides OS-agnostic
+wrappers for both the POSIX and Win32 memory mapped file capabilities.
+
+WWW: http://search.cpan.org/dist/IPC-Mmap/
diff --git a/devel/p5-IPC-Mmap/pkg-plist b/devel/p5-IPC-Mmap/pkg-plist
new file mode 100644
index 000000000000..47cb62591e64
--- /dev/null
+++ b/devel/p5-IPC-Mmap/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Mmap/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Mmap/Mmap.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Mmap/Mmap.so
+%%SITE_PERL%%/%%PERL_ARCH%%/IPC/Mmap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/IPC/Mmap.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/IPC/Mmap/POSIX.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/IPC/Mmap/Win32.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Mmap
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/IPC/Mmap
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/IPC