aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-PAR
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-08-28 15:31:10 +0800
committerdemon <demon@FreeBSD.org>2003-08-28 15:31:10 +0800
commit10fad12c18a371a91c28a60e62128c563c07d7ee (patch)
tree3e02bb5a3c2af8c07a927d5f64c40721da22b4d7 /devel/p5-PAR
parentb1aca2a9303b5372fb4cb0fb0a64c847b73c59dc (diff)
downloadfreebsd-ports-gnome-10fad12c18a371a91c28a60e62128c563c07d7ee.tar.gz
freebsd-ports-gnome-10fad12c18a371a91c28a60e62128c563c07d7ee.tar.zst
freebsd-ports-gnome-10fad12c18a371a91c28a60e62128c563c07d7ee.zip
New port: p5-PAR.
The PAR Toolkit is a cross between Java's JAR and Perl2EXE; It makes cross-platform packaging and deployment a breeze for Perl programmers. Notable features include: * Turn your Perl programs into ready-to-run executables * Pack scripts and requered libraries with a binary loader * Put PAR files into @INC to avoid version conflicts * Works with remote URL as well as local files * Supports XS modules and DATA sections * Turns CPAN module distributions into PAR distributions * Install, uninstall, signs and verifies PAR distributions * Runs scripts inside PAR files, generated by "pp -p" Submitted by: Autrijus Tang <autrijus@autrijus.org>
Diffstat (limited to 'devel/p5-PAR')
-rw-r--r--devel/p5-PAR/Makefile31
-rw-r--r--devel/p5-PAR/distinfo1
-rw-r--r--devel/p5-PAR/pkg-descr13
-rw-r--r--devel/p5-PAR/pkg-plist12
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/p5-PAR/Makefile b/devel/p5-PAR/Makefile
new file mode 100644
index 000000000000..46b580f22599
--- /dev/null
+++ b/devel/p5-PAR/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-PAR
+# Date created: Aug 27 2003
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PAR
+PORTVERSION= 0.74
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AU/AUTRIJUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Perl Archive Toolkit
+
+BUILD_DEPENDS= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/Module/ScanDeps.pm:${PORTSDIR}/devel/p5-Module-ScanDeps \
+ ${SITE_PERL}/Module/Signature.pm:${PORTSDIR}/security/p5-Module-Signature \
+ ${SITE_PERL}/PAR/Dist.pm:${PORTSDIR}/devel/p5-PAR-Dist
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= par.pl.1 parl.1 pp.1
+MAN3= App::Packer::PAR.3 PAR.3 PAR::Heavy.3 PAR::Intro.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-PAR/distinfo b/devel/p5-PAR/distinfo
new file mode 100644
index 000000000000..38a7ecbda1e3
--- /dev/null
+++ b/devel/p5-PAR/distinfo
@@ -0,0 +1 @@
+MD5 (PAR-0.74.tar.gz) = 646af8c792372c78bcf542799b1e8d9b
diff --git a/devel/p5-PAR/pkg-descr b/devel/p5-PAR/pkg-descr
new file mode 100644
index 000000000000..a8fa5da840dd
--- /dev/null
+++ b/devel/p5-PAR/pkg-descr
@@ -0,0 +1,13 @@
+The PAR Toolkit is a cross between Java's JAR and Perl2EXE; It makes
+cross-platform packaging and deployment a breeze for Perl programmers.
+
+Notable features include:
+
+* Turn your Perl programs into ready-to-run executables
+* Pack scripts and requered libraries with a binary loader
+* Put PAR files into @INC to avoid version conflicts
+* Works with remote URL as well as local files
+* Supports XS modules and DATA sections
+* Turns CPAN module distributions into PAR distributions
+* Install, uninstall, signs and verifies PAR distributions
+* Runs scripts inside PAR files, generated by "pp -p"
diff --git a/devel/p5-PAR/pkg-plist b/devel/p5-PAR/pkg-plist
new file mode 100644
index 000000000000..6bea98936c01
--- /dev/null
+++ b/devel/p5-PAR/pkg-plist
@@ -0,0 +1,12 @@
+bin/parl
+bin/pp
+bin/par.pl
+%%SITE_PERL%%/App/Packer/PAR.pm
+%%SITE_PERL%%/PAR.pm
+%%SITE_PERL%%/PAR/Heavy.pm
+%%SITE_PERL%%/PAR/Intro.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PAR/.packlist
+@dirrm %%SITE_PERL%%/App/Packer
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/PAR
+@unexec rmdir %D/%%SITE_PERL%%/App 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/PAR 2>/dev/null || true