aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Perl6-Rules
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2007-07-29 02:05:51 +0800
committerchinsan <chinsan@FreeBSD.org>2007-07-29 02:05:51 +0800
commitc4404fed9077a511b75168164fa6c47dbae92bec (patch)
treecbb2fcf8eb4e5c20f16c552f66fa3354fc10e5fa /devel/p5-Perl6-Rules
parentb1d6acb16fd8368b2681a387b7316a603ef86fb1 (diff)
downloadfreebsd-ports-gnome-c4404fed9077a511b75168164fa6c47dbae92bec.tar.gz
freebsd-ports-gnome-c4404fed9077a511b75168164fa6c47dbae92bec.tar.zst
freebsd-ports-gnome-c4404fed9077a511b75168164fa6c47dbae92bec.zip
Add p5-Perl6-Rules, this module implements a close simulation of the Perl 6
rule and grammar constructs, translating them back to Perl 5 regexes via a source filter. (And hence suffers from all the usual limitations of a source filter, including the ability to translate complex code spectacularly wrongly). Approved by: rafan (mentor, implicit)
Diffstat (limited to 'devel/p5-Perl6-Rules')
-rw-r--r--devel/p5-Perl6-Rules/Makefile26
-rw-r--r--devel/p5-Perl6-Rules/distinfo3
-rw-r--r--devel/p5-Perl6-Rules/pkg-descr6
-rw-r--r--devel/p5-Perl6-Rules/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-Perl6-Rules/Makefile b/devel/p5-Perl6-Rules/Makefile
new file mode 100644
index 000000000000..551f82785c2a
--- /dev/null
+++ b/devel/p5-Perl6-Rules/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Perl6-Rules
+# Date created: 2007/07/28
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl6-Rules
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Perl6
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Implements (most of) the Perl 6 regex syntax
+
+BUILD_DEPENDS= p5-Attribute-Handlers>=0:${PORTSDIR}/devel/p5-Attribute-Handlers \
+ p5-Filter-Simple>=0:${PORTSDIR}/textproc/p5-Filter-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Perl6::Rules.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Perl6-Rules/distinfo b/devel/p5-Perl6-Rules/distinfo
new file mode 100644
index 000000000000..8a85d1fee517
--- /dev/null
+++ b/devel/p5-Perl6-Rules/distinfo
@@ -0,0 +1,3 @@
+MD5 (Perl6-Rules-0.03.tar.gz) = fa9ce190ce4d085234423941d73bf1c5
+SHA256 (Perl6-Rules-0.03.tar.gz) = ad4924f400e234db2835e93a54c84112d8d1056cf2a515c1879e17a763dd6aa3
+SIZE (Perl6-Rules-0.03.tar.gz) = 125685
diff --git a/devel/p5-Perl6-Rules/pkg-descr b/devel/p5-Perl6-Rules/pkg-descr
new file mode 100644
index 000000000000..168c0a133bfe
--- /dev/null
+++ b/devel/p5-Perl6-Rules/pkg-descr
@@ -0,0 +1,6 @@
+This module implements a close simulation of the Perl 6 rule and grammar
+constructs, translating them back to Perl 5 regexes via a source filter.
+(And hence suffers from all the usual limitations of a source filter,
+including the ability to translate complex code spectacularly wrongly).
+
+WWW: http://search.cpan.org/dist/Perl6-Rules/
diff --git a/devel/p5-Perl6-Rules/pkg-plist b/devel/p5-Perl6-Rules/pkg-plist
new file mode 100644
index 000000000000..c56f44a51de2
--- /dev/null
+++ b/devel/p5-Perl6-Rules/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6/Rules/.packlist
+%%SITE_PERL%%/Perl6/Rules.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6/Rules
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6
+@dirrmtry %%SITE_PERL%%/Perl6