aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-RunApp
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-12-29 18:18:24 +0800
committerrafan <rafan@FreeBSD.org>2006-12-29 18:18:24 +0800
commit8e03ac91aa2ea5c530a6f9f9d8544bf30d55c9c3 (patch)
tree9d48c17c1b56804ec27b149a95328dc754dbd811 /devel/p5-RunApp
parent0e60942d9cb5df4ec5e5f05e71b87353e01ecd3a (diff)
downloadfreebsd-ports-gnome-8e03ac91aa2ea5c530a6f9f9d8544bf30d55c9c3.tar.gz
freebsd-ports-gnome-8e03ac91aa2ea5c530a6f9f9d8544bf30d55c9c3.tar.zst
freebsd-ports-gnome-8e03ac91aa2ea5c530a6f9f9d8544bf30d55c9c3.zip
Add p5-RunApp 0.13, a generic module to run web-applications.
Diffstat (limited to 'devel/p5-RunApp')
-rw-r--r--devel/p5-RunApp/Makefile37
-rw-r--r--devel/p5-RunApp/distinfo3
-rw-r--r--devel/p5-RunApp/pkg-descr8
-rw-r--r--devel/p5-RunApp/pkg-plist16
4 files changed, 64 insertions, 0 deletions
diff --git a/devel/p5-RunApp/Makefile b/devel/p5-RunApp/Makefile
new file mode 100644
index 000000000000..ad9073f1285b
--- /dev/null
+++ b/devel/p5-RunApp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-RunApp
+# Date created: Dec 29 2006
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RunApp
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLKAO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= A generic module to run web-applications
+
+BUILD_DEPENDS= p5-App-Control>=0:${PORTSDIR}/devel/p5-App-Control \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
+
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= App::Control::Apache.3 \
+ RunApp.3 \
+ RunApp::Apache.3 \
+ RunApp::Base.3 \
+ RunApp::Control.3 \
+ RunApp::Control::ApacheCtl.3 \
+ RunApp::Control::AppControl.3 \
+ RunApp::Cron.3 \
+ RunApp::Template.3 \
+ RunApp::Template::Apache.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-RunApp/distinfo b/devel/p5-RunApp/distinfo
new file mode 100644
index 000000000000..cbd8c9a08d4d
--- /dev/null
+++ b/devel/p5-RunApp/distinfo
@@ -0,0 +1,3 @@
+MD5 (RunApp-0.13.tar.gz) = d41e2f5255f43b23fdd7d8834307c122
+SHA256 (RunApp-0.13.tar.gz) = afb15b1da9b3b1dca9ac3224d5520bfd9524130dfbbb3b3cc79edb14a518679b
+SIZE (RunApp-0.13.tar.gz) = 31333
diff --git a/devel/p5-RunApp/pkg-descr b/devel/p5-RunApp/pkg-descr
new file mode 100644
index 000000000000..9b95f535dc1b
--- /dev/null
+++ b/devel/p5-RunApp/pkg-descr
@@ -0,0 +1,8 @@
+RunApp streamlines the process for configuring applications that
+requires one or more web servers and/or other daemons, during
+development or deployment.
+
+It builds the config files required by the services from the $config
+hash, such as apache's httpd.conf.
+
+WWW: http://search.cpan.org/dist/RunApp/
diff --git a/devel/p5-RunApp/pkg-plist b/devel/p5-RunApp/pkg-plist
new file mode 100644
index 000000000000..fd60875a27f0
--- /dev/null
+++ b/devel/p5-RunApp/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/App/Control/Apache.pm
+%%SITE_PERL%%/RunApp.pm
+%%SITE_PERL%%/RunApp/Apache.pm
+%%SITE_PERL%%/RunApp/Base.pm
+%%SITE_PERL%%/RunApp/Control.pm
+%%SITE_PERL%%/RunApp/Control/ApacheCtl.pm
+%%SITE_PERL%%/RunApp/Control/AppControl.pm
+%%SITE_PERL%%/RunApp/Cron.pm
+%%SITE_PERL%%/RunApp/Template.pm
+%%SITE_PERL%%/RunApp/Template/Apache.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/RunApp/.packlist
+@dirrmtry %%SITE_PERL%%/App/Control
+@dirrmtry %%SITE_PERL%%/RunApp/Template
+@dirrmtry %%SITE_PERL%%/RunApp/Control
+@dirrmtry %%SITE_PERL%%/RunApp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/RunApp