aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pcre++
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-03-16 15:29:19 +0800
committerpat <pat@FreeBSD.org>2002-03-16 15:29:19 +0800
commit1f96ef07ed8b5490d4107f2da2b352b852cfa416 (patch)
treed6608ceb4a526fbdc2ee58152167238c38307359 /devel/pcre++
parent0a4a6f887297dc06b0ef97339bdbdef2f4d99823 (diff)
downloadfreebsd-ports-gnome-1f96ef07ed8b5490d4107f2da2b352b852cfa416.tar.gz
freebsd-ports-gnome-1f96ef07ed8b5490d4107f2da2b352b852cfa416.tar.zst
freebsd-ports-gnome-1f96ef07ed8b5490d4107f2da2b352b852cfa416.zip
Support CXXFLAGS/LOCALBASE properly
PR: 35958 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'devel/pcre++')
-rw-r--r--devel/pcre++/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/devel/pcre++/Makefile b/devel/pcre++/Makefile
index 8134c326be0f..38f807be7961 100644
--- a/devel/pcre++/Makefile
+++ b/devel/pcre++/Makefile
@@ -13,19 +13,27 @@ MASTER_SITES= ftp://ftp.daemon.de/scip/Apps/pcre++/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+PCRE_CONFIG?= ${LOCALBASE}/bin/pcre-config
-USE_LIBTOOL= yes
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="`${PCRE_CONFIG} --cflags`" \
+ LDFLAGS="`${PCRE_CONFIG} --libs`"
INSTALLS_SHLIB= yes
MAN3= Pcre.3
-.if !defined(NOPORTDOCS)
+post-patch:
+ @${PERL} -pi -e 's|-I/usr/local/include||g ; \
+ s|-L/usr/local/lib||g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-O -g|\@CXXFLAGS\@|g' ${WRKSRC}/Makefile.in
+
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/html/ ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/*.* ${DOCSDIR}
.endif
.include <bsd.port.mk>