aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-XML_RSS/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-12-28 15:55:47 +0800
committeredwin <edwin@FreeBSD.org>2003-12-28 15:55:47 +0800
commitd1c66c82a563be8eb2f4c7b6e96c75d3adb7eb1c (patch)
tree84003698ad2fd8363cbe0ecd528aef690cbacd97 /devel/pear-XML_RSS/Makefile
parente77dff7e6230eea7acc0d504c3c918517180e95a (diff)
downloadfreebsd-ports-gnome-d1c66c82a563be8eb2f4c7b6e96c75d3adb7eb1c.tar.gz
freebsd-ports-gnome-d1c66c82a563be8eb2f4c7b6e96c75d3adb7eb1c.tar.zst
freebsd-ports-gnome-d1c66c82a563be8eb2f4c7b6e96c75d3adb7eb1c.zip
[PATCH] simplify pear-* ports
These patches do the following things for PEAR ports: * devel-pear-PEAR-Makefile.common.patch - provides a do-install target and all that jazz in devel/pear-PEAR/Makefile.common - individual PEAR ports now just set a few variables: * pear-ports-Makefile.common-ng.patch contains changes for all pear-* ports including devel/pear-PEAR See http://smradoch.innuendo.cz/FreeBSD/ for complete description. Note: still missing are: devel/pear-HTML_Common devel/pear-I18N net/pear-Net_NNTP security/pear-Auth PR: ports/59213 Submitted by: Roman Neuhauser <neuhauser@bellavista.cz>
Diffstat (limited to 'devel/pear-XML_RSS/Makefile')
-rw-r--r--devel/pear-XML_RSS/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/devel/pear-XML_RSS/Makefile b/devel/pear-XML_RSS/Makefile
index 27183c75c554..590f56bd2655 100644
--- a/devel/pear-XML_RSS/Makefile
+++ b/devel/pear-XML_RSS/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XML_RSS
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= devel www pear
MAINTAINER= ports@FreeBSD.org
@@ -16,21 +17,10 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS} \
${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-
-TESTDIR= ${PEARDIR}/tests/${PORTNAME}
-
-do-install:
- @${MKDIR} ${PEARDIR}/XML
- @${CP} -fp ${WRKSRC}/RSS.php ${PEARDIR}/XML
- @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/XML/RSS.php
- @${CHMOD} ${SHAREMODE} ${PEARDIR}/XML/RSS.php
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${TESTDIR}
- @${CP} -p ${WRKSRC}/tests/* ${TESTDIR}
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${TESTDIR}
- @${CHMOD} -R ${SHAREMODE} ${TESTDIR}/*
-.endif
+CATEGORY= XML
+FILES= RSS.php
+TESTS= test.rss 01-parse.phpt
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>