aboutsummaryrefslogtreecommitdiffstats
path: root/devel/php-java-bridge
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-06-22 10:43:08 +0800
committerChin-San Huang <chinsan@FreeBSD.org>2008-06-22 10:43:08 +0800
commit82f6760946ef0cffcea1bf056b4442e3180eff74 (patch)
treeee8571f362c63b676a09830a21673980755db4cb /devel/php-java-bridge
parentfdb93bc808e659ba135ba9d095312bc811535171 (diff)
downloadfreebsd-ports-gnome-82f6760946ef0cffcea1bf056b4442e3180eff74.tar.gz
freebsd-ports-gnome-82f6760946ef0cffcea1bf056b4442e3180eff74.tar.zst
freebsd-ports-gnome-82f6760946ef0cffcea1bf056b4442e3180eff74.zip
The php/Java bridge is an optimized, XML-based network protocol, which can
be used to connect a native script engine, PHP, with a Java or ECMA 335 virtual machine. It is more than 50 times faster than local RPC via SOAP, requires less resources on the web-server side, and it is faster and more reliable than direct communication via the Java Native Interface. J2EE back end clustering and Apache load balancing are supported as well as running PHP scripts within JSP, JSF or other frameworks. The php/Java bridge allows you to quickly access java classes from within your PHP scripts without having to know Java. It also allows you to access PHP scripts from within your Java classes without having to know PHP. WWW: http://php-java-bridge.sourceforge.net/
Diffstat (limited to 'devel/php-java-bridge')
-rw-r--r--devel/php-java-bridge/Makefile56
-rw-r--r--devel/php-java-bridge/distinfo3
-rw-r--r--devel/php-java-bridge/pkg-descr14
3 files changed, 73 insertions, 0 deletions
diff --git a/devel/php-java-bridge/Makefile b/devel/php-java-bridge/Makefile
new file mode 100644
index 000000000000..5fdcbd67b276
--- /dev/null
+++ b/devel/php-java-bridge/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: php-java-bridge
+# Date created: 2008/06/04
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= php-java-bridge
+PORTVERSION= 5.2.2
+CATEGORIES= devel java
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= PHP module wich connects the PHP object with the Java/ECMA 335 object
+
+USE_AUTOTOOLS= autoconf:261:env automake:19:env libtool:15:env
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+#CONFIGURE_ARGS+=--prefix=${PREFIX} \
+# --disable-backend \
+# --disable-servlet \
+# --with-jdk-home="${JAVA_HOME}"
+USE_JAVA= yes
+JAVA_BUILD= jdk
+
+USE_PHP= session
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+PHP_MODNAME= java
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-configure:
+ (cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${PHPBASE}/bin/phpize)
+ (cd ${WRKSRC}; ./configure --with-java="${JAVA_HOME}")
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/modules/JavaBridge.jar \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/modules/RunJavaBridge \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/modules/libnatcJavaBridge.a \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/modules/libnatcJavaBridge.so \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ ${ECHO_CMD} "lib/php/${PHP_EXT_DIR}/JavaBridge.jar" \
+ >> ${TMPPLIST}
+ ${ECHO_CMD} "lib/php/${PHP_EXT_DIR}/RunJavaBridge" \
+ >> ${TMPPLIST}
+ ${ECHO_CMD} "lib/php/${PHP_EXT_DIR}/libnatcJavaBridge.a" \
+ >> ${TMPPLIST}
+ ${ECHO_CMD} "lib/php/${PHP_EXT_DIR}/libnatcJavaBridge.so" \
+ >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/php-java-bridge/distinfo b/devel/php-java-bridge/distinfo
new file mode 100644
index 000000000000..7d4e4afec9ef
--- /dev/null
+++ b/devel/php-java-bridge/distinfo
@@ -0,0 +1,3 @@
+MD5 (php-java-bridge_5.2.2.tar.gz) = ef23c2de3d09105a199962a8a6bd7ac4
+SHA256 (php-java-bridge_5.2.2.tar.gz) = 54114a5f9f7002dea81e50e980201fc148375f9ae268d0165e2745e998735480
+SIZE (php-java-bridge_5.2.2.tar.gz) = 11811820
diff --git a/devel/php-java-bridge/pkg-descr b/devel/php-java-bridge/pkg-descr
new file mode 100644
index 000000000000..296890b1dd5e
--- /dev/null
+++ b/devel/php-java-bridge/pkg-descr
@@ -0,0 +1,14 @@
+The php/Java bridge is an optimized, XML-based network protocol, which can
+be used to connect a native script engine, PHP, with a Java or ECMA 335
+virtual machine. It is more than 50 times faster than local RPC via SOAP,
+requires less resources on the web-server side, and it is faster and more
+reliable than direct communication via the Java Native Interface.
+
+J2EE back end clustering and Apache load balancing are supported as well as
+running PHP scripts within JSP, JSF or other frameworks.
+
+The php/Java bridge allows you to quickly access java classes from within
+your PHP scripts without having to know Java. It also allows you to access
+PHP scripts from within your Java classes without having to know PHP.
+
+WWW: http://php-java-bridge.sourceforge.net/