aboutsummaryrefslogtreecommitdiffstats
path: root/devel/poslib/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-30 08:56:20 +0800
committeredwin <edwin@FreeBSD.org>2003-08-30 08:56:20 +0800
commitb94f0fbfd78a6b3ba18773e2b133e59fafaa81a3 (patch)
tree4660ac43497645ba55fb2656173c7c8c908eef15 /devel/poslib/Makefile
parentc5e48552cb1291ec0b1f7ba25bb1ed8b62bc5f60 (diff)
downloadfreebsd-ports-gnome-b94f0fbfd78a6b3ba18773e2b133e59fafaa81a3.tar.gz
freebsd-ports-gnome-b94f0fbfd78a6b3ba18773e2b133e59fafaa81a3.tar.zst
freebsd-ports-gnome-b94f0fbfd78a6b3ba18773e2b133e59fafaa81a3.zip
[NEW PORT] devel/poslib: Posadis C++ DNS library
Poslib is a portable C++ DNS library, a part of Posadis project. It consists of two parts: a client library and a server library. Using the client library, you can simply develop applications that use the Domain Name System (DNS). It includes many functions for resolving, domain-name manipulation and Resource Record (RR) creation. The server library, based on the client core, can be used to develop DNS servers. By implementing a query entry-point function using the Poslib library of functions, you can easily create DNS servers, without worrying about low-level details such as DNS message compilation, domain-name compression and UDP/TCP transmission. Author: Meilof Veeningen <meilof@users.sourceforge.net> WWW: http://posadis.sourceforge.net/projects/poslib.php PR: ports/55195 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Diffstat (limited to 'devel/poslib/Makefile')
-rw-r--r--devel/poslib/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/poslib/Makefile b/devel/poslib/Makefile
new file mode 100644
index 000000000000..a140491a83fa
--- /dev/null
+++ b/devel/poslib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: poslib
+# Date created: 2003-08-03
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= poslib
+PORTVERSION= 1.0
+CATEGORIES= devel dns
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= posadis
+
+MAINTAINER= sergei@kolobov.com
+COMMENT= Posadis C++ DNS library
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS} -D_REENTRANT"
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+DOCS= AUTHORS ChangeLog NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>