aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ptlib26
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2009-02-22 03:01:07 +0800
committergabor <gabor@FreeBSD.org>2009-02-22 03:01:07 +0800
commit1b5be1c95f97ea582e525b344a36d50f6893c1c1 (patch)
tree993e696b55ef1bef788928a2b7db9a779dd45b02 /devel/ptlib26
parente058c792e8a83d75ee1d0bb27ad2fdb0fad85bee (diff)
downloadfreebsd-ports-gnome-1b5be1c95f97ea582e525b344a36d50f6893c1c1.tar.gz
freebsd-ports-gnome-1b5be1c95f97ea582e525b344a36d50f6893c1c1.tar.zst
freebsd-ports-gnome-1b5be1c95f97ea582e525b344a36d50f6893c1c1.zip
PWLib is a multi-platform code library that can be used to write
applications that will compile and run on the BSD Unixes, Windows, Linux and a few other Unix variants. It was developed by Equivalence Ltd Pty. It is used by the OpenH323 library. WWW: http://www.openh323.org/ PR: ports/131129 Submitted by: "Eric L. Chen" <d9364104@mail.nchu.edu.tw>
Diffstat (limited to 'devel/ptlib26')
-rw-r--r--devel/ptlib26/Makefile141
-rw-r--r--devel/ptlib26/distinfo3
-rw-r--r--devel/ptlib26/files/patch-Makefile.in24
-rw-r--r--devel/ptlib26/files/patch-include_ptclib_vsdl.h11
-rw-r--r--devel/ptlib26/files/patch-plugins_vidinput_bsd_h11
-rw-r--r--devel/ptlib26/files/patch-src__ptlib__common__osutils.cxx27
-rw-r--r--devel/ptlib26/files/patch-src__ptlib__unix__svcproc.cxx26
-rw-r--r--devel/ptlib26/files/patch-src__ptlib__unix__tlib.cxx11
-rw-r--r--devel/ptlib26/files/patch-src__ptlib__unix__tlibthrd.cxx47
-rw-r--r--devel/ptlib26/files/patch-src_ptclib_vsdl.cxx11
-rw-r--r--devel/ptlib26/pkg-descr7
-rw-r--r--devel/ptlib26/pkg-plist178
12 files changed, 497 insertions, 0 deletions
diff --git a/devel/ptlib26/Makefile b/devel/ptlib26/Makefile
new file mode 100644
index 000000000000..ae29967e8dfc
--- /dev/null
+++ b/devel/ptlib26/Makefile
@@ -0,0 +1,141 @@
+# New ports collection makefile for: pwlib
+# Date created: Fri Aug 22 07:11:44 GMT 2003
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptlib
+PORTVERSION= 2.4.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/ptlib/2.4
+DISTNAME= ptlib-${PORTVERSION}
+
+MAINTAINER= d9364104@mail.nchu.edu.tw
+COMMENT= A cross platform C++ library, used by OpenH323
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+CONFLICTS= pwlib-*
+
+USE_BISON= build
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget
+WANT_GNOME= yes
+WANT_SDL= yes
+USE_OPENSSL= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
+CONFIGURE_ENV= \
+ OPENSSL_CFLAGS="-I/usr/include" \
+ OPENSSL_LIBS="-lssl"
+CONFIGURE_ARGS+= \
+ --disable-atomicity \
+ --with-expat-dir="${LOCALBASE}" \
+ --enable-oss \
+ --disable-odbc
+
+# if explicitely asked for, depend upon it
+.if defined(WITH_SDL)
+USE_SDL+= sdl
+CONFIGURE_ENV+= SDL_CFLAGS="`sdl-config --cflags`" \
+ SDL_LIBS="`sdl-config --libs`"
+MAKE_ENV+= SDL_CFLAGS="`sdl-config --cflags`" \
+ SDL_LIBS="`sdl-config --libs`"
+.endif
+
+# if explicitely disabled, do not depend upon it
+.if defined(WITHOUT_SDL)
+CONFIGURE_ARGS+= --disable-sdl
+.endif
+
+# if nobody cares, use it if it is installed already
+.if !defined(WITHOUT_SDL) && !defined(WITH_SDL)
+.if ${HAVE_SDL:Msdl}
+USE_SDL+= sdl
+CONFIGURE_ENV+= SDL_CFLAGS="`sdl-config --cflags`" \
+ SDL_LIBS="`sdl-config --libs`"
+MAKE_ENV+= SDL_CFLAGS="`sdl-config --cflags`" \
+ SDL_LIBS="`sdl-config --libs`"
+.else
+CONFIGURE_ARGS+= --disable-sdl
+.endif
+.endif
+
+.if !defined(WITHOUT_PLUGINS)
+CONFIGURE_ARGS+= --enable-plugins
+.endif
+
+#disable OpenLDAP support in PWLIB
+.if defined(WITHOUT_LDAP)
+CONFIGURE_ARGS+= --disable-openldap
+.else
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+= --enable-openldap --with-ldap-dir="${LOCALBASE}"
+.endif
+
+# ONLY FOR THE BRAVE!
+# If someone owns a firewire(4) video device and wants to use it for
+# video-conferencing purposes, please download the files:
+# libraw1394.shar.gz, libavc1394.shar.gz and libdc1394.shar.gz from
+# ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/ports/
+# Extract the files in ${PORTSDIR}/devel and uncomment the following lines.
+#
+##enable libavc1394
+#.if defined(WITH_AVC1394)
+#LIB_DEPENDS+= avc1394.2:${PORTSDIR}/devel/libavc1394 \
+# dv.4:${PORTSDIR}/multimedia/libdv
+#CONFIGURE_ARGS+= --enable-avc
+#PLIST_SUB+= AVC1394=""
+#.else
+CONFIGURE_ARGS+= --disable-avc
+PLIST_SUB+= AVC1394="@comment "
+#.endif
+#
+##enable libdc1394
+#.if defined(WITH_DC1394)
+#LIB_DEPENDS+= dc1394_control.13:${PORTSDIR}/devel/libdc1394
+#CONFIGURE_ARGS+= --enable-dc
+#PLIST_SUB+= DC1394=""
+#.else
+CONFIGURE_ARGS+= --disable-dc
+PLIST_SUB+= DC1394="@comment "
+#.endif
+
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+CFLAGS+= -fPIC
+.endif
+
+.if (${ARCH} == "i386") || (${ARCH} == "ia64") || (${ARCH} == "amd64") || (${ARCH} == "sparc64")
+CONFIGURE_ARGS+=--enable-bsdvideo
+PLIST_SUB+= BSDVIDEO=""
+.else
+CONFIGURE_ARGS+=--disable-bsdvideo
+PLIST_SUB+= BSDVIDEO="@comment "
+.endif
+
+.if defined(WITH_V4L) || ( exists(${LOCALBASE}/include/linux/videodev.h) && \
+ !defined(WITHOUT_V4L) )
+CONFIGURE_ARGS+=--enable-v4l
+PLIST_SUB+= V4L=""
+BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
+.else
+CONFIGURE_ARGS+=--disable-v4l
+PLIST_SUB+= V4L="@comment "
+.endif
+
+post-patch:
+.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
+ @${REINPLACE_CMD} -e 's|P_PTHREADS_XPG6|0|' \
+ ${WRKSRC}/src/ptlib/unix/tlibthrd.cxx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ptlib26/distinfo b/devel/ptlib26/distinfo
new file mode 100644
index 000000000000..0d5bad28694d
--- /dev/null
+++ b/devel/ptlib26/distinfo
@@ -0,0 +1,3 @@
+MD5 (ptlib-2.4.4.tar.gz) = fe64e92187a864f92fda11c7fafc12f1
+SHA256 (ptlib-2.4.4.tar.gz) = bb8ba95d522f0767d8e3bead7512a05fbffce5abaeb9ec1c6e1ed2ccc02a24d1
+SIZE (ptlib-2.4.4.tar.gz) = 4308282
diff --git a/devel/ptlib26/files/patch-Makefile.in b/devel/ptlib26/files/patch-Makefile.in
new file mode 100644
index 000000000000..9ae1fc01d3ec
--- /dev/null
+++ b/devel/ptlib26/files/patch-Makefile.in
@@ -0,0 +1,24 @@
+--- Makefile.in.orig 2009-01-11 17:53:18.000000000 -0500
++++ Makefile.in 2009-01-26 15:09:22.000000000 -0500
+@@ -120,9 +120,9 @@
+ $(INSTALL) -m 755 make/ptlib-config $(DESTDIR)$(PREFIX)/share/ptlib/make/
+ (cd $(DESTDIR)$(PREFIX)/bin; rm -f ptlib-config ; ln -snf ../share/ptlib/make/ptlib-config ptlib-config)
+
+- mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig
+- chmod 755 $(DESTDIR)$(LIBDIR)/pkgconfig
+- $(INSTALL) -m 644 ptlib.pc $(DESTDIR)$(LIBDIR)/pkgconfig/
++ mkdir -p $(DESTDIR)$(PREFIX)/libdata/pkgconfig
++ chmod 755 $(DESTDIR)$(PREFIX)/libdata/pkgconfig
++ $(INSTALL) -m 644 ptlib.pc $(DESTDIR)$(PREFIX)/libdata/pkgconfig/
+ uninstall:
+ rm -rf $(DESTDIR)$(PREFIX)/include/ptlib \
+ $(DESTDIR)$(PREFIX)/include/ptclib \
+@@ -130,7 +130,7 @@
+ $(DESTDIR)$(PREFIX)/include/ptbuildopts.h \
+ $(DESTDIR)$(PREFIX)/share/ptlib \
+ $(DESTDIR)$(LIBDIR)/$(DEV_PLUGIN_DIR) \
+- $(DESTDIR)$(LIBDIR)/pkgconfig/ptlib.pc
++ $(DESTDIR)$(PREFIX)/libdata/pkgconfig/ptlib.pc
+ rm -f $(DESTDIR)$(LIBDIR)/lib$(PTLIB_BASE)_s.a \
+ $(DESTDIR)$(LIBDIR)/$(PTLIB_FILE) \
+ $(DESTDIR)$(LIBDIR)/$(PTLIB_FILE).@MAJOR_VERSION@.@MINOR_VERSION@@BUILD_TYPE@@BUILD_NUMBER@
diff --git a/devel/ptlib26/files/patch-include_ptclib_vsdl.h b/devel/ptlib26/files/patch-include_ptclib_vsdl.h
new file mode 100644
index 000000000000..9a375b4df972
--- /dev/null
+++ b/devel/ptlib26/files/patch-include_ptclib_vsdl.h
@@ -0,0 +1,11 @@
+--- include/ptclib/vsdl.h.orig 2008-09-25 14:51:15.000000000 +0800
++++ include/ptclib/vsdl.h 2008-09-25 14:52:15.000000000 +0800
+@@ -33,7 +33,7 @@
+
+ #include <ptlib.h>
+ #if defined(P_FREEBSD)
+-#include <SDL11/SDL.h>
++#include <SDL.h>
+ #else
+ #include <SDL/SDL.h>
+ #endif
diff --git a/devel/ptlib26/files/patch-plugins_vidinput_bsd_h b/devel/ptlib26/files/patch-plugins_vidinput_bsd_h
new file mode 100644
index 000000000000..913e457670ad
--- /dev/null
+++ b/devel/ptlib26/files/patch-plugins_vidinput_bsd_h
@@ -0,0 +1,11 @@
+--- plugins/vidinput_bsd/vidinput_bsd.h.orig 2009-01-11 17:52:59.000000000 -0500
++++ plugins/vidinput_bsd/vidinput_bsd.h 2009-01-26 17:55:00.000000000 -0500
+@@ -62,7 +62,7 @@
+
+ static PStringList GetInputDeviceNames();
+
+- PStringList GetDeviceNames() const
++ PStringArray GetDeviceNames() const
+ { return GetInputDeviceNames(); }
+
+ PINDEX GetMaxFrameBytes();
diff --git a/devel/ptlib26/files/patch-src__ptlib__common__osutils.cxx b/devel/ptlib26/files/patch-src__ptlib__common__osutils.cxx
new file mode 100644
index 000000000000..742e7d8b2fe1
--- /dev/null
+++ b/devel/ptlib26/files/patch-src__ptlib__common__osutils.cxx
@@ -0,0 +1,27 @@
+--- ./src/ptlib/common/osutils.cxx.orig 2009-02-14 22:04:50.000000000 +0100
++++ ./src/ptlib/common/osutils.cxx 2009-02-14 22:04:55.000000000 +0100
+@@ -2152,21 +2152,21 @@
+ PReadWriteMutex::Nest * PReadWriteMutex::GetNest() const
+ {
+ PWaitAndSignal mutex(nestingMutex);
+- return nestedThreads.GetAt(POrdinalKey((PINDEX)PThread::GetCurrentThreadId()));
++ return nestedThreads.GetAt(POrdinalKey((unsigned long)PThread::GetCurrentThreadId()));
+ }
+
+
+ void PReadWriteMutex::EndNest()
+ {
+ nestingMutex.Wait();
+- nestedThreads.RemoveAt(POrdinalKey((PINDEX)PThread::GetCurrentThreadId()));
++ nestedThreads.RemoveAt(POrdinalKey((unsigned long)PThread::GetCurrentThreadId()));
+ nestingMutex.Signal();
+ }
+
+
+ PReadWriteMutex::Nest & PReadWriteMutex::StartNest()
+ {
+- POrdinalKey threadId = (PINDEX)PThread::GetCurrentThreadId();
++ POrdinalKey threadId = (unsigned long)PThread::GetCurrentThreadId();
+
+ nestingMutex.Wait();
+
diff --git a/devel/ptlib26/files/patch-src__ptlib__unix__svcproc.cxx b/devel/ptlib26/files/patch-src__ptlib__unix__svcproc.cxx
new file mode 100644
index 000000000000..6fe5f399d6b0
--- /dev/null
+++ b/devel/ptlib26/files/patch-src__ptlib__unix__svcproc.cxx
@@ -0,0 +1,26 @@
+--- ./src/ptlib/unix/svcproc.cxx.orig 2009-02-14 22:03:27.000000000 +0100
++++ ./src/ptlib/unix/svcproc.cxx 2009-02-14 22:03:32.000000000 +0100
+@@ -165,7 +165,7 @@
+ #elif defined(BE_THREADS)
+ thread_id tid = ::find_thread(NULL);
+ #else
+- unsigned tid = (unsigned) pthread_self();
++ unsigned long tid = (unsigned long)pthread_self();
+ #endif
+ *out << "ThreadID=0x"
+ << setfill('0') << ::hex
+@@ -719,12 +719,12 @@
+ #elif defined(BE_THREADS)
+ thread_id tid = ::find_thread(NULL);
+ #else
+- unsigned tid = (unsigned) pthread_self();
++ unsigned long tid = (unsigned long)pthread_self();
+ #endif
+ PThread * thread_ptr = activeThreads.GetAt(tid);
+
+ char msg[200];
+- sprintf(msg, "\nCaught %s, thread_id=%u", sigmsg, tid);
++ sprintf(msg, "\nCaught %s, thread_id=%lu", sigmsg, tid);
+
+ if (thread_ptr != NULL) {
+ PString thread_name = thread_ptr->GetThreadName();
diff --git a/devel/ptlib26/files/patch-src__ptlib__unix__tlib.cxx b/devel/ptlib26/files/patch-src__ptlib__unix__tlib.cxx
new file mode 100644
index 000000000000..c0f11e3062ac
--- /dev/null
+++ b/devel/ptlib26/files/patch-src__ptlib__unix__tlib.cxx
@@ -0,0 +1,11 @@
+--- ./src/ptlib/unix/tlib.cxx.orig 2009-02-14 22:02:51.000000000 +0100
++++ ./src/ptlib/unix/tlib.cxx 2009-02-14 22:03:09.000000000 +0100
+@@ -400,7 +400,7 @@
+ {
+ if (PProcessInstance != NULL) {
+ PWaitAndSignal m(PProcessInstance->threadMutex);
+- PThread & thread = PProcessInstance->activeThreads[(unsigned)id];
++ PThread & thread = PProcessInstance->activeThreads[(unsigned long)id];
+ return thread.GetThreadName();
+ }
+ return psprintf("%08x", id);
diff --git a/devel/ptlib26/files/patch-src__ptlib__unix__tlibthrd.cxx b/devel/ptlib26/files/patch-src__ptlib__unix__tlibthrd.cxx
new file mode 100644
index 000000000000..4339d642a33e
--- /dev/null
+++ b/devel/ptlib26/files/patch-src__ptlib__unix__tlibthrd.cxx
@@ -0,0 +1,47 @@
+--- ./src/ptlib/unix/tlibthrd.cxx.orig 2009-02-14 22:04:11.000000000 +0100
++++ ./src/ptlib/unix/tlibthrd.cxx 2009-02-14 22:04:18.000000000 +0100
+@@ -216,7 +216,7 @@
+ {
+ PWaitAndSignal m(threadMutex);
+
+- if (!activeThreads.Contains((unsigned)id))
++ if (!activeThreads.Contains((unsigned long)id))
+ return PFalse;
+
+ return pthread_kill(id, sig) == 0;
+@@ -254,7 +254,7 @@
+ #endif
+
+ ((PProcess *)this)->activeThreads.DisallowDeleteObjects();
+- ((PProcess *)this)->activeThreads.SetAt((unsigned)PX_threadId, this);
++ ((PProcess *)this)->activeThreads.SetAt((unsigned long)PX_threadId, this);
+
+ PX_firstTimeStart = PFalse;
+ }
+@@ -370,7 +370,7 @@
+ PAssertPTHREAD(pthread_create, (&PX_threadId, &threadAttr, PX_ThreadStart, this));
+
+ // put the thread into the thread list
+- process.activeThreads.SetAt((unsigned)PX_threadId, this);
++ process.activeThreads.SetAt((unsigned long)PX_threadId, this);
+ if (process.activeThreads.GetSize() > highWaterMark)
+ newHighWaterMark = highWaterMark = process.activeThreads.GetSize();
+
+@@ -693,7 +693,7 @@
+ {
+ PProcess & process = PProcess::Current();
+ process.threadMutex.Wait();
+- PThread * thread = process.activeThreads.GetAt((unsigned)pthread_self());
++ PThread * thread = process.activeThreads.GetAt((unsigned long)pthread_self());
+ process.threadMutex.Signal();
+ return thread;
+ }
+@@ -834,7 +834,7 @@
+ }
+
+ // remove this thread from the active thread list
+- process.activeThreads.SetAt((unsigned)id, NULL);
++ process.activeThreads.SetAt((unsigned long)id, NULL);
+
+ // delete the thread if required, note this is done this way to avoid
+ // a race condition, the thread ID cannot be zeroed before the if!
diff --git a/devel/ptlib26/files/patch-src_ptclib_vsdl.cxx b/devel/ptlib26/files/patch-src_ptclib_vsdl.cxx
new file mode 100644
index 000000000000..5485f017ae53
--- /dev/null
+++ b/devel/ptlib26/files/patch-src_ptclib_vsdl.cxx
@@ -0,0 +1,11 @@
+--- src/ptclib/vsdl.cxx.orig 2008-09-25 14:50:57.000000000 +0800
++++ src/ptclib/vsdl.cxx 2008-09-25 14:51:48.000000000 +0800
+@@ -44,7 +44,7 @@
+ extern "C" {
+
+ #if defined(P_FREEBSD)
+-#include <SDL11/SDL.h>
++#include <SDL.h>
+ #else
+ #include <SDL/SDL.h>
+ #endif
diff --git a/devel/ptlib26/pkg-descr b/devel/ptlib26/pkg-descr
new file mode 100644
index 000000000000..c6a71d32ca39
--- /dev/null
+++ b/devel/ptlib26/pkg-descr
@@ -0,0 +1,7 @@
+PWLib is a multi-platform code library that can be used to write
+applications that will compile and run on the BSD Unixes, Windows, Linux
+and a few other Unix variants. It was developed by Equivalence Ltd Pty.
+
+It is used by the OpenH323 library.
+
+WWW: http://www.openh323.org/
diff --git a/devel/ptlib26/pkg-plist b/devel/ptlib26/pkg-plist
new file mode 100644
index 000000000000..3ff54b240aca
--- /dev/null
+++ b/devel/ptlib26/pkg-plist
@@ -0,0 +1,178 @@
+bin/ptlib-config
+include/ptclib/asnber.h
+include/ptclib/asner.h
+include/ptclib/asnper.h
+include/ptclib/asnxer.h
+include/ptclib/cypher.h
+include/ptclib/delaychan.h
+include/ptclib/dtmf.h
+include/ptclib/enum.h
+include/ptclib/ftp.h
+include/ptclib/guid.h
+include/ptclib/html.h
+include/ptclib/http.h
+include/ptclib/httpform.h
+include/ptclib/httpsvc.h
+include/ptclib/inetmail.h
+include/ptclib/inetprot.h
+include/ptclib/ipacl.h
+include/ptclib/memfile.h
+include/ptclib/mime.h
+include/ptclib/modem.h
+include/ptclib/paec.h
+include/ptclib/pasn.h
+include/ptclib/pdns.h
+include/ptclib/pils.h
+include/ptclib/pldap.h
+include/ptclib/pnat.h
+include/ptclib/podbc.h
+include/ptclib/psasl.h
+include/ptclib/psnmp.h
+include/ptclib/psoap.h
+include/ptclib/psockbun.h
+include/ptclib/pssl.h
+include/ptclib/pstun.h
+include/ptclib/ptts.h
+include/ptclib/pvfiledev.h
+include/ptclib/pvidfile.h
+include/ptclib/pwavfile.h
+include/ptclib/pwavfiledev.h
+include/ptclib/pxml.h
+include/ptclib/pxmlrpc.h
+include/ptclib/pxmlrpcs.h
+include/ptclib/qchannel.h
+include/ptclib/random.h
+include/ptclib/rfc1155.h
+include/ptclib/shttpsvc.h
+include/ptclib/snmp.h
+include/ptclib/sockagg.h
+include/ptclib/socks.h
+include/ptclib/telnet.h
+include/ptclib/url.h
+include/ptclib/vsdl.h
+include/ptclib/vxml.h
+include/ptclib/xmpp.h
+include/ptclib/xmpp_c2s.h
+include/ptclib/xmpp_muc.h
+include/ptclib/xmpp_roster.h
+@dirrm include/ptclib
+include/ptlib/unix/ptlib/beaudio.h
+include/ptlib/unix/ptlib/bevideo.h
+include/ptlib/unix/ptlib/channel.h
+include/ptlib/unix/ptlib/conchan.h
+include/ptlib/unix/ptlib/config.h
+include/ptlib/unix/ptlib/contain.h
+include/ptlib/unix/ptlib/critsec.h
+include/ptlib/unix/ptlib/dynalink.h
+include/ptlib/unix/ptlib/ethsock.h
+include/ptlib/unix/ptlib/file.h
+include/ptlib/unix/ptlib/filepath.h
+include/ptlib/unix/ptlib/icmpsock.h
+include/ptlib/unix/ptlib/ipdsock.h
+include/ptlib/unix/ptlib/ipsock.h
+include/ptlib/unix/ptlib/maccoreaudio.h
+include/ptlib/unix/ptlib/mutex.h
+include/ptlib/unix/ptlib/pdirect.h
+include/ptlib/unix/ptlib/pipechan.h
+include/ptlib/unix/ptlib/pmachdep.h
+include/ptlib/unix/ptlib/pprocess.h
+include/ptlib/unix/ptlib/ptime.h
+include/ptlib/unix/ptlib/ptlib.inl
+include/ptlib/unix/ptlib/remconn.h
+include/ptlib/unix/ptlib/resampler.h
+include/ptlib/unix/ptlib/semaphor.h
+include/ptlib/unix/ptlib/serchan.h
+include/ptlib/unix/ptlib/sfile.h
+include/ptlib/unix/ptlib/shmvideo.h
+include/ptlib/unix/ptlib/socket.h
+include/ptlib/unix/ptlib/sound.h
+include/ptlib/unix/ptlib/svcproc.h
+include/ptlib/unix/ptlib/syncpoint.h
+include/ptlib/unix/ptlib/tcpsock.h
+include/ptlib/unix/ptlib/textfile.h
+include/ptlib/unix/ptlib/thread.h
+include/ptlib/unix/ptlib/timeint.h
+include/ptlib/unix/ptlib/timer.h
+include/ptlib/unix/ptlib/udpsock.h
+include/ptlib/unix/ptlib/video.h
+include/ptlib/unix/ptlib/videoio.h
+@dirrm include/ptlib/unix/ptlib
+@dirrm include/ptlib/unix
+include/ptlib/MacMainIf.h
+include/ptlib/args.h
+include/ptlib/array.h
+include/ptlib/channel.h
+include/ptlib/conchan.h
+include/ptlib/config.h
+include/ptlib/contain.h
+include/ptlib/contain.inl
+include/ptlib/critsec.h
+include/ptlib/devplugin.h
+include/ptlib/dict.h
+include/ptlib/dynalink.h
+include/ptlib/ethsock.h
+include/ptlib/file.h
+include/ptlib/filepath.h
+include/ptlib/icmpsock.h
+include/ptlib/indchan.h
+include/ptlib/int64.h
+include/ptlib/ipdsock.h
+include/ptlib/ipsock.h
+include/ptlib/ipxsock.h
+include/ptlib/lists.h
+include/ptlib/mail.h
+include/ptlib/mutex.h
+include/ptlib/notifier.h
+include/ptlib/notifier_ext.h
+include/ptlib/object.h
+include/ptlib/osutil.inl
+include/ptlib/pdirect.h
+include/ptlib/pfactory.h
+include/ptlib/pipechan.h
+include/ptlib/plugin.h
+include/ptlib/pluginmgr.h
+include/ptlib/pprocess.h
+include/ptlib/psharedptr.h
+include/ptlib/pstring.h
+include/ptlib/psync.h
+include/ptlib/ptime.h
+include/ptlib/qos.h
+include/ptlib/remconn.h
+include/ptlib/safecoll.h
+include/ptlib/semaphor.h
+include/ptlib/serchan.h
+include/ptlib/sfile.h
+include/ptlib/smartptr.h
+include/ptlib/socket.h
+include/ptlib/sockets.h
+include/ptlib/sound.h
+include/ptlib/spxsock.h
+include/ptlib/svcproc.h
+include/ptlib/syncpoint.h
+include/ptlib/syncthrd.h
+include/ptlib/tcpsock.h
+include/ptlib/textfile.h
+include/ptlib/thread.h
+include/ptlib/timeint.h
+include/ptlib/timer.h
+include/ptlib/udpsock.h
+include/ptlib/vconvert.h
+include/ptlib/video.h
+include/ptlib/videoio.h
+include/ptlib/videoio1394dc.h
+@dirrm include/ptlib
+include/ptlib.h
+share/ptlib/make/common.mak
+share/ptlib/make/lib.mak
+share/ptlib/make/plugins.mak
+share/ptlib/make/ptbuildopts.mak
+share/ptlib/make/ptlib-config
+share/ptlib/make/ptlib.mak
+share/ptlib/make/unix.mak
+@dirrm share/ptlib/make
+@dirrm share/ptlib
+lib/libpt.so.2.4.4
+lib/libpt.so.2.4
+lib/libpt.so.2
+lib/libpt_s.a
+libdata/pkgconfig/ptlib.pc