aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ptlib
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-19 04:07:35 +0800
committerpav <pav@FreeBSD.org>2009-12-19 04:07:35 +0800
commit66339f93b8969be6f7c60f8733da05b97a249e1e (patch)
tree2ed25f50eed017db8948c9b9b03cd12b1cbb0952 /devel/ptlib
parentb2d04234b8ffdd1595045dfcca6f7d85ac0c7678 (diff)
downloadfreebsd-ports-gnome-66339f93b8969be6f7c60f8733da05b97a249e1e.tar.gz
freebsd-ports-gnome-66339f93b8969be6f7c60f8733da05b97a249e1e.tar.zst
freebsd-ports-gnome-66339f93b8969be6f7c60f8733da05b97a249e1e.zip
- Unbreak on 8.x
PR: ports/141395 Submitted by: Eric L. Chen <lihong@ieee.org> (maintainer)
Diffstat (limited to 'devel/ptlib')
-rw-r--r--devel/ptlib/Makefile2
-rw-r--r--devel/ptlib/files/extra-src_ptlib_unix_socket.cxx13
2 files changed, 14 insertions, 1 deletions
diff --git a/devel/ptlib/Makefile b/devel/ptlib/Makefile
index a3da6115efff..09b1a43f5bf9 100644
--- a/devel/ptlib/Makefile
+++ b/devel/ptlib/Makefile
@@ -31,7 +31,7 @@ NO_LATEST_LINK= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 800059
-BROKEN= does not build
+EXTRA_PATCHES= ${FILESDIR}/extra-src_ptlib_unix_socket.cxx
.endif
CONFIGURE_ENV= \
diff --git a/devel/ptlib/files/extra-src_ptlib_unix_socket.cxx b/devel/ptlib/files/extra-src_ptlib_unix_socket.cxx
new file mode 100644
index 000000000000..733c579b31d8
--- /dev/null
+++ b/devel/ptlib/files/extra-src_ptlib_unix_socket.cxx
@@ -0,0 +1,13 @@
+--- src/ptlib/unix/socket.cxx.orig 2009-12-12 11:42:03.000000000 +0800
++++ src/ptlib/unix/socket.cxx 2009-12-12 11:46:09.000000000 +0800
+@@ -1144,10 +1144,6 @@ PBoolean process_rtentry(struct rt_msghd
+ if ((~rtm->rtm_flags&RTF_LLINFO)
+ #if defined(P_NETBSD) || defined(P_QNX)
+ && (~rtm->rtm_flags&RTF_CLONED) // Net BSD has flag one way
+-#elif !defined(P_OPENBSD)
+- && (~rtm->rtm_flags&RTF_WASCLONED) // Free BSD/MAC has it another
+-#else
+- // Open BSD does not have it at all!
+ #endif
+ ) {
+