aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-bsd
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-27 06:31:36 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-27 06:31:36 +0800
commit33c8aabee311cc08f00d49b7ccd278da11931f4a (patch)
treeb83022fa712f89f95abb1eaa0227b8355b1892fa /devel/py-bsd
parent46b000695b3cc1403a2a2496d4f51b222877d2ad (diff)
downloadfreebsd-ports-gnome-33c8aabee311cc08f00d49b7ccd278da11931f4a.tar.gz
freebsd-ports-gnome-33c8aabee311cc08f00d49b7ccd278da11931f4a.tar.zst
freebsd-ports-gnome-33c8aabee311cc08f00d49b7ccd278da11931f4a.zip
Simplify Makefile: use PY_ENUM34
With hat: python
Diffstat (limited to 'devel/py-bsd')
-rw-r--r--devel/py-bsd/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/devel/py-bsd/Makefile b/devel/py-bsd/Makefile
index 79f9a2e3d0ce..0ccd98c41c67 100644
--- a/devel/py-bsd/Makefile
+++ b/devel/py-bsd/Makefile
@@ -11,7 +11,8 @@ COMMENT= Python wrappers for various BSD libc and system calls
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+RUN_DEPENDS= ${PY_ENUM34} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
USES= python
USE_PYTHON= autoplist distutils cython
@@ -21,10 +22,4 @@ GH_ACCOUNT= freenas
GH_PROJECT= py-bsd
GH_TAGNAME= 6d148fa
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34@${FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>