aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pymacs
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-12 15:28:45 +0800
committerpav <pav@FreeBSD.org>2005-09-12 15:28:45 +0800
commita2797fa5f4c1cd336146cdba419e7315a7d1d753 (patch)
tree6660b2bf2cae7280dee7995be24b9b188e07bccf /devel/pymacs
parentfe361b3f4bb50238db87e7e65fb0d41114e19001 (diff)
downloadfreebsd-ports-gnome-a2797fa5f4c1cd336146cdba419e7315a7d1d753.tar.gz
freebsd-ports-gnome-a2797fa5f4c1cd336146cdba419e7315a7d1d753.tar.zst
freebsd-ports-gnome-a2797fa5f4c1cd336146cdba419e7315a7d1d753.zip
Pymacs is a powerful tool which, once started from Emacs, allows both-way
communication between Emacs Lisp and Python. Pymacs aims Python as an extension language for Emacs rather than the other way around, and this assymetry is reflected in some design choices. Within Emacs Lisp code, one may load and use Python modules. Python functions may themselves use Emacs services, and handle Emacs Lisp objects kept in Emacs Lisp space. PR: ports/85995 Submitted by: Mike Meyer <mwm@mired.org>
Diffstat (limited to 'devel/pymacs')
-rw-r--r--devel/pymacs/Makefile33
-rw-r--r--devel/pymacs/distinfo2
-rw-r--r--devel/pymacs/pkg-descr8
-rw-r--r--devel/pymacs/pkg-message9
-rw-r--r--devel/pymacs/pkg-plist28
5 files changed, 80 insertions, 0 deletions
diff --git a/devel/pymacs/Makefile b/devel/pymacs/Makefile
new file mode 100644
index 000000000000..d29b99bd5ef9
--- /dev/null
+++ b/devel/pymacs/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: pymacs
+# Date created: 23 July 2005
+# Whom: mwm@mired.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pymacs
+PORTVERSION= 0.22
+CATEGORIES= devel editors python elisp
+MASTER_SITES= http://pymacs.progiciels-bpi.ca/archives/ \
+ ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+
+MAINTAINER= mwm@mired.org
+COMMENT= A Python package for scripting emacs
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_PYTHON_PREFIX= yes
+USE_EMACS= yes
+
+.if !defined(EMACS_PORT_NAME)
+EMACS_PORT_NAME=xemacs21
+.endif
+
+# Install the emacs side of things
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pymacs.el ${PREFIX}/${EMACS_SITE_LISPDIR}
+ ${EMACS_NAME} -batch -f batch-byte-compile \
+ ${PREFIX}/${EMACS_SITE_LISPDIR}/pymacs.el
+
+.include <bsd.port.mk>
diff --git a/devel/pymacs/distinfo b/devel/pymacs/distinfo
new file mode 100644
index 000000000000..9bb9ef2358b4
--- /dev/null
+++ b/devel/pymacs/distinfo
@@ -0,0 +1,2 @@
+MD5 (Pymacs-0.22.tar.gz) = 73b7a641be100fd90a9be59ecf01fd98
+SIZE (Pymacs-0.22.tar.gz) = 363119
diff --git a/devel/pymacs/pkg-descr b/devel/pymacs/pkg-descr
new file mode 100644
index 000000000000..59e861f5424a
--- /dev/null
+++ b/devel/pymacs/pkg-descr
@@ -0,0 +1,8 @@
+Pymacs is a powerful tool which, once started from Emacs, allows both-way
+communication between Emacs Lisp and Python. Pymacs aims Python as an
+extension language for Emacs rather than the other way around, and this
+assymetry is reflected in some design choices. Within Emacs Lisp code, one
+may load and use Python modules. Python functions may themselves use Emacs
+services, and handle Emacs Lisp objects kept in Emacs Lisp space.
+
+WWW: http://pymacs.progiciels-bpi.ca/
diff --git a/devel/pymacs/pkg-message b/devel/pymacs/pkg-message
new file mode 100644
index 000000000000..9c9e5b3a7e1d
--- /dev/null
+++ b/devel/pymacs/pkg-message
@@ -0,0 +1,9 @@
+Add the following to your emacs initialization file to enable pymacs:
+
+(autoload 'pymacs-load "pymacs" nil t)
+(autoload 'pymacs-eval "pymacs" nil t)
+(autoload 'pymacs-apply "pymacs")
+(autoload 'pymacs-call "pymacs")
+
+See http://pymacs.progiciels-bpi.ca/manual/index.html for
+documentation on using pymacs.
diff --git a/devel/pymacs/pkg-plist b/devel/pymacs/pkg-plist
new file mode 100644
index 000000000000..66f53433b062
--- /dev/null
+++ b/devel/pymacs/pkg-plist
@@ -0,0 +1,28 @@
+%%EMACS_SITE_LISPDIR%%/pymacs.el
+%%EMACS_SITE_LISPDIR%%/pymacs.elc
+bin/pymacs-services
+bin/rebox
+%%PYTHON_SITELIBDIR%%/Pymacs/pymacs.py
+%%PYTHON_SITELIBDIR%%/Pymacs/__init__.py
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/nncourriel.py
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/folder.py
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/__init__.py
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/nncourriel.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/folder.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/nncourriel.pyo
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/folder.pyo
+%%PYTHON_SITELIBDIR%%/Pymacs/Nn/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/__init__.py
+%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/rebox.py
+%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/rebox.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/rebox.pyo
+%%PYTHON_SITELIBDIR%%/Pymacs/pymacs.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs/pymacs.pyo
+%%PYTHON_SITELIBDIR%%/Pymacs/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/Pymacs/Nn
+@dirrm %%PYTHON_SITELIBDIR%%/Pymacs/Rebox
+@dirrm %%PYTHON_SITELIBDIR%%/Pymacs