aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qca/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-04-29 06:43:59 +0800
committerAdriaan de Groot <adridg@FreeBSD.org>2019-04-29 06:43:59 +0800
commit0391a2ca46fa40015a73f5ef1867baadc6e2bb12 (patch)
tree89aa0365c7d1e9d44cda115afa048d2637d7f6db /devel/qca/Makefile
parent2e596e3fc45ab341d847b9a453bb44d38261b628 (diff)
downloadfreebsd-ports-gnome-0391a2ca46fa40015a73f5ef1867baadc6e2bb12.tar.gz
freebsd-ports-gnome-0391a2ca46fa40015a73f5ef1867baadc6e2bb12.tar.zst
freebsd-ports-gnome-0391a2ca46fa40015a73f5ef1867baadc6e2bb12.zip
Fix devel/qca's BOTAN option.
This was missing all the moving parts to actually get the botan plugin to build.
Diffstat (limited to 'devel/qca/Makefile')
-rw-r--r--devel/qca/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/devel/qca/Makefile b/devel/qca/Makefile
index 49dfb843e6f5..af152fa7fe81 100644
--- a/devel/qca/Makefile
+++ b/devel/qca/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qca
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KDE/stable/qca/${PORTVERSION}
PKGNAMESUFFIX= -qt5
@@ -33,7 +34,9 @@ OPTIONS_DEFINE= BOTAN GNUPG OPENSSL SASL TEST
OPTIONS_DEFAULT=GNUPG OPENSSL
OPTIONS_SUB= yes
+BOTAN_CMAKE_ON= -DWITH_botan_PLUGIN=yes
BOTAN_LIB_DEPENDS= libbotan-2.so:security/botan2
+BOTAN_USES= pkgconfig
GNUPG_CMAKE_ON= -DWITH_gnupg_PLUGIN=yes
GNUPG_RUN_DEPENDS= gpg2:security/gnupg