aboutsummaryrefslogtreecommitdiffstats
path: root/devel/renpy
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-07-24 08:06:10 +0800
committerjbeich <jbeich@FreeBSD.org>2015-07-24 08:06:10 +0800
commit6ad4f424ef1fd00e7f650745a8444b89c65c4474 (patch)
tree7cf0e1d2ef6c3eaa585a8a9ec66804d8c718c440 /devel/renpy
parentea67c144dfb88ad3f468ec502532e1a1c5b79e0d (diff)
downloadfreebsd-ports-gnome-6ad4f424ef1fd00e7f650745a8444b89c65c4474.tar.gz
freebsd-ports-gnome-6ad4f424ef1fd00e7f650745a8444b89c65c4474.tar.zst
freebsd-ports-gnome-6ad4f424ef1fd00e7f650745a8444b89c65c4474.zip
devel/py-game_sdl2, devel/renpy: update to 6.99.5 and switch to -sdk
- Install runtimes necessary to build game distributions for non-FreeBSD [1] - Use vendor bytecode to avoid an issue with saves and workaround build now failing without X11 connection Changes: http://www.renpy.org/doc/html/changelog.html#ren-py-6-99-5 PR: 201322 [1]
Diffstat (limited to 'devel/renpy')
-rw-r--r--devel/renpy/Makefile33
-rw-r--r--devel/renpy/distinfo4
2 files changed, 21 insertions, 16 deletions
diff --git a/devel/renpy/Makefile b/devel/renpy/Makefile
index 824386953019..ae187713c914 100644
--- a/devel/renpy/Makefile
+++ b/devel/renpy/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= renpy
-PORTVERSION= 6.99.4
-DISTVERSIONSUFFIX=-source
+PORTVERSION= 6.99.5
+DISTVERSIONSUFFIX=-sdk
CATEGORIES= devel games
MASTER_SITES= http://www.renpy.org/dl/${PORTVERSION}/
#MASTER_SITES+= GENTOO
@@ -16,14 +16,14 @@ LICENSE_NAME_DejaVu= Bitstream Vera and Arev fonts license
LICENSE_FILE_DejaVu= ${WRKSRC}/renpy/common/DejaVuSans.txt
LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:${PORTSDIR}/devel/py-game_sdl2 \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>=6.99.5:${PORTSDIR}/devel/py-game_sdl2 \
cython:${PORTSDIR}/lang/cython
LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi \
libGLEW.so:${PORTSDIR}/graphics/glew \
libpng.so:${PORTSDIR}/graphics/png \
libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
libfreetype.so:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:${PORTSDIR}/devel/py-game_sdl2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>=6.99.5:${PORTSDIR}/devel/py-game_sdl2
# Upstream tends to reroll distfiles before moving under /release/
PORTSCOUT= site:http://www.renpy.org/dl/release/
@@ -31,14 +31,13 @@ PORTSCOUT= site:http://www.renpy.org/dl/release/
USES= python:2.7 shebangfix tar:bz2
USE_PYTHON= autoplist distutils
USE_SDL= sdl2
-EXTRACT_AFTER_ARGS=--exclude gen --exclude '*.py[co]'
+EXTRACT_AFTER_ARGS=--exclude gen --exclude '*.py[co]' --exclude 'pythonlib*'
SHEBANG_FILES= renpy.py launcher/game/tkaskdir.py
python_OLD_CMD= /usr/bin/env python
python_CMD= ${PYTHON_CMD}
BUILD_WRKSRC= ${WRKSRC}/module
INSTALL_WRKSRC= ${BUILD_WRKSRC}
MAKE_ENV+= RENPY_DEPS_INSTALL="${LOCALBASE}"
-PYDISTUTILS_BUILDPATH=${BUILD_WRKSRC}/build/lib.${OPSYS:tl}-${UNAMER}-${ARCH}-${PYTHON_VER}
PORTDATA= launcher renpy renpy.py templates
PORTDOCS= *
PLIST_FILES= bin/${PORTNAME}
@@ -50,14 +49,26 @@ DESKTOP_ENTRIES="Ren'Py" \
"Development;Game;AdventureGame;" \
""
-OPTIONS_DEFAULT=TKINTER
-OPTIONS_DEFINE= DOCS EXAMPLES TKINTER
+OPTIONS_DEFAULT=TKINTER DIST
+OPTIONS_DEFINE= DOCS DIST EXAMPLES TKINTER
+DIST_DESC= Distribution runtimes for Windows, OS X, Linux
TKINTER_DESC= Install Tkinter to allow choosing Projects Directory
TKINTER_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MDIST}
+LICENSE+= ART20 PSFL
+PORTDATA+= lib renpy.app renpy.exe renpy.sh
+. for lic in FREETYPE LIBJPEG LIBPNG MSVCR90
+LICENSE+= ${lic}
+LICENSE_NAME_${lic}= ${lic} license
+LICENSE_FILE_${lic}= ${WRKSRC}/LICENSE.txt
+LICENSE_PERMS_${lic}= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+. endfor
+.endif
+
.if ${PORT_OPTIONS:MEXAMPLES}
PORTDATA+= the_question tutorial
.endif
@@ -71,12 +82,6 @@ post-patch:
post-build:
@${PYTHON_CMD} -m compileall -d ${DATADIR} ${WRKSRC}
@${PYTHON_CMD} -O -m compileall -d ${DATADIR} ${WRKSRC}
-# XXX Replace WRKSRC with DATADIR in bytecode
- @(cd ${WRKSRC} && for d in */game templates/*; do \
- ${SETENV} HOME=${WRKDIR} \
- PYTHONPATH="${PYTHONPATH}:${PYDISTUTILS_BUILDPATH}" \
- ${PYTHON_CMD} ${WRKSRC}/renpy.py $$d compile; \
- done)
add-plist-post: add-empty-dirs
add-empty-dirs:
diff --git a/devel/renpy/distinfo b/devel/renpy/distinfo
index a902a31cc41b..fec671ef5bb4 100644
--- a/devel/renpy/distinfo
+++ b/devel/renpy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (renpy-6.99.4-source.tar.bz2) = bb574bb847bc71bc5c507a176235cd074fdd44e2660a999c1c7767c5ed9e1633
-SIZE (renpy-6.99.4-source.tar.bz2) = 23465980
+SHA256 (renpy-6.99.5-sdk.tar.bz2) = fef030f4fc6d3b1f9f6fb634005721acbc12a54bf6064ebf7c7458bb977267e6
+SIZE (renpy-6.99.5-sdk.tar.bz2) = 52888481