aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-property
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
committerknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
commite932a87c5235b90fa671f5b453afd18c94f3b2f3 (patch)
tree7f470d6c370885834b1ad0e7ffcd9a38f0534974 /devel/ruby-property
parent761a287d6d458a83abfd6ab90410b27c5cda14af (diff)
downloadfreebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.gz
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.zst
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Diffstat (limited to 'devel/ruby-property')
-rw-r--r--devel/ruby-property/Makefile14
-rw-r--r--devel/ruby-property/pkg-descr3
-rw-r--r--devel/ruby-property/pkg-plist2
3 files changed, 10 insertions, 9 deletions
diff --git a/devel/ruby-property/Makefile b/devel/ruby-property/Makefile
index 196aff414c54..4fa41440dbb5 100644
--- a/devel/ruby-property/Makefile
+++ b/devel/ruby-property/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: Ruby-property
-# Date created: 7 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+# New ports collection makefile for: Ruby-property
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
@@ -22,15 +22,15 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
post-patch:
${PERL} -i -pe 's|rubyapi.css|../rubyapi.css|g' ${WRKSRC}/Properties-ja.html
do-install:
- ${INSTALL_DATA} ${WRKSRC}/property.rb ${PREFIX}/lib/ruby/site_ruby
+ ${INSTALL_DATA} ${WRKSRC}/property.rb ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ruby/property/ja
.for f in property-example.rb test.default property.README Properties.html rubyapi.css
diff --git a/devel/ruby-property/pkg-descr b/devel/ruby-property/pkg-descr
index d7e76cbc328e..3959177ab01d 100644
--- a/devel/ruby-property/pkg-descr
+++ b/devel/ruby-property/pkg-descr
@@ -4,4 +4,5 @@ This library, developed after java.util.Properties class of Java
Language, provides simple properties scheme for application
configurations, resources, locale data, etc.
-WWW: http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/index.html
+Author: Hiroshi IGARASHI <igarashi@ueda.info.waseda.ac.jp>
+WWW: http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/Properties.html
diff --git a/devel/ruby-property/pkg-plist b/devel/ruby-property/pkg-plist
index 6df5ac314cef..24df63d345b1 100644
--- a/devel/ruby-property/pkg-plist
+++ b/devel/ruby-property/pkg-plist
@@ -1,4 +1,4 @@
-lib/ruby/site_ruby/property.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/property.rb
share/doc/ruby/property/property-example.rb
share/doc/ruby/property/test.default
share/doc/ruby/property/property.README