aboutsummaryrefslogtreecommitdiffstats
path: root/devel/sdl12
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-01-09 04:43:31 +0800
committersobomax <sobomax@FreeBSD.org>2003-01-09 04:43:31 +0800
commit395a7da5af76a09811d9eb9b91ea609c663a28b5 (patch)
tree97964de259de710b99e33c97b00eae7b2d79ce33 /devel/sdl12
parent0c63c552d3eaff899f1296ffddb8a3746924a24b (diff)
downloadfreebsd-ports-gnome-395a7da5af76a09811d9eb9b91ea609c663a28b5.tar.gz
freebsd-ports-gnome-395a7da5af76a09811d9eb9b91ea609c663a28b5.tar.zst
freebsd-ports-gnome-395a7da5af76a09811d9eb9b91ea609c663a28b5.zip
Use REINPLACE_CMD.
PR: 46835 Submitted by: Ulrich Spoerlein <q@uni.de>
Diffstat (limited to 'devel/sdl12')
-rw-r--r--devel/sdl12/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index eb0a5a0e42bb..891833a2225e 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
@@ -86,7 +87,7 @@ post-configure:
@cd ${WRKSRC} && \
${CP} sdl-config sdl11-config && \
${CP} sdl.m4 sdl11.m4
- @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ @${REINPLACE_CMD} 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
post-install: