aboutsummaryrefslogtreecommitdiffstats
path: root/devel/sdl12
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-10 06:19:37 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-10 06:19:37 +0800
commitd158dbd02a1e85cc24190c1e511c9cfba8d36aee (patch)
tree1e89899e36e0281bb13c19d2317703388280f668 /devel/sdl12
parent14ede720121c8a96002bcbbc96305ed2792b9669 (diff)
downloadfreebsd-ports-gnome-d158dbd02a1e85cc24190c1e511c9cfba8d36aee.tar.gz
freebsd-ports-gnome-d158dbd02a1e85cc24190c1e511c9cfba8d36aee.tar.zst
freebsd-ports-gnome-d158dbd02a1e85cc24190c1e511c9cfba8d36aee.zip
Instead of disabling joystick code completely use "dummy" driver instead of
problematic usb one. This should fix problems some ports are having when linked against libsdl without joystick code at all. Bump PORTREVISION.
Diffstat (limited to 'devel/sdl12')
-rw-r--r--devel/sdl12/Makefile4
-rw-r--r--devel/sdl12/files/patch-ac12
2 files changed, 10 insertions, 6 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index a23e0b87cdbb..e44ea28421ed 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl
PORTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.libsdl.org/release/ \
http://www.devolution.com/~slouken/SDL/release/
@@ -26,8 +27,7 @@ CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-video-aalib \
--disable-arts \
- --disable-nas \
- --disable-joystick
+ --disable-nas
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/devel/sdl12/files/patch-ac b/devel/sdl12/files/patch-ac
index 3d322f5c6890..48def1ccf2de 100644
--- a/devel/sdl12/files/patch-ac
+++ b/devel/sdl12/files/patch-ac
@@ -2,7 +2,7 @@
$FreeBSD$
--- configure.orig Sun Apr 14 02:57:31 2002
-+++ configure Wed Apr 17 14:31:32 2002
++++ configure Fri May 10 01:04:55 2002
@@ -670,9 +670,9 @@
# libtool versioning
@@ -35,10 +35,14 @@ $FreeBSD$
;;
*-*-netbsd*)
pthread_cflags="-I/usr/pkg/include -D_REENTRANT"
-@@ -6702,6 +6702,7 @@
+@@ -6700,8 +6700,9 @@
+ #fi
+ # Set up files for the joystick library
if test x$enable_joystick = xyes; then
- JOYSTICK_SUBDIRS="$JOYSTICK_SUBDIRS bsd"
- JOYSTICK_DRIVERS="$JOYSTICK_DRIVERS bsd/libjoystick_bsd.la"
+- JOYSTICK_SUBDIRS="$JOYSTICK_SUBDIRS bsd"
+- JOYSTICK_DRIVERS="$JOYSTICK_DRIVERS bsd/libjoystick_bsd.la"
++ JOYSTICK_SUBDIRS="$JOYSTICK_SUBDIRS dummy"
++ JOYSTICK_DRIVERS="$JOYSTICK_DRIVERS dummy/libjoystick_dummy.la"
+ SYSTEM_LIBS="$SYSTEM_LIBS $USB_LIBS"
fi
# Set up files for the cdrom library