aboutsummaryrefslogtreecommitdiffstats
path: root/devel/sfml/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-06-18 19:46:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-06-18 19:46:51 +0800
commitdf95a2d560d09c86d1a500fe7c6e846a721ff3bf (patch)
treee391a5b5894d27043bb95bd6680b03174979f810 /devel/sfml/Makefile
parent3de9e5720382e61bea8dbab6e1287a0b29e64dc0 (diff)
downloadfreebsd-ports-gnome-df95a2d560d09c86d1a500fe7c6e846a721ff3bf.tar.gz
freebsd-ports-gnome-df95a2d560d09c86d1a500fe7c6e846a721ff3bf.tar.zst
freebsd-ports-gnome-df95a2d560d09c86d1a500fe7c6e846a721ff3bf.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful
Diffstat (limited to 'devel/sfml/Makefile')
-rw-r--r--devel/sfml/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/devel/sfml/Makefile b/devel/sfml/Makefile
index 42f1633c9ef6..83aebf00c602 100644
--- a/devel/sfml/Makefile
+++ b/devel/sfml/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sfml
-# Date created: 07 Jul 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sfml
PORTVERSION= 1.6
@@ -15,10 +11,10 @@ DISTNAME= SFML-${PORTVERSION}-sdk-linux-32
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Simple and Fast Multimedia Library
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile \
+ jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype:${PORTSDIR}/print/freetype2
USE_GMAKE= yes
USE_OPENAL= al
@@ -34,6 +30,8 @@ PORTDOCS= *
PORTSCOUT= limit:[^c]$$
+.include <bsd.port.options.mk>
+
post-extract:
@${RM} -f ${WRKSRC}/lib/*
@${FIND} ${WRKSRC}/samples/bin/ -type f -maxdepth 1 -delete
@@ -42,7 +40,7 @@ post-install:
.for lib in audio graphics network system window
@${LN} -s libsfml-${lib}.so.${PORTVERSION} ${PREFIX}/lib/libsfml-${lib}.so.${PORTVERSION:C/^([0-9]).*/\1/}
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "*" ${DOCSDIR}/
.endif