aboutsummaryrefslogtreecommitdiffstats
path: root/devel/silentbob
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-11-19 22:01:19 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-11-19 22:01:19 +0800
commit4f550dd6f2967e55281626d12f11070cf384f517 (patch)
tree466ec9de6a1847f1c6c85d4dc373051124f3787c /devel/silentbob
parent437ecfe12338ab6d3363ebe080fac98e074c7d19 (diff)
downloadfreebsd-ports-gnome-4f550dd6f2967e55281626d12f11070cf384f517.tar.gz
freebsd-ports-gnome-4f550dd6f2967e55281626d12f11070cf384f517.tar.zst
freebsd-ports-gnome-4f550dd6f2967e55281626d12f11070cf384f517.zip
"SilentBob" is a tool to help a programmer/team manager to digest
and comprehend either a simple program or a big source code tree based on the source code by presenting the code in a searcheable and tagged way. It helps to speed up the learning curve and to make it more convenient to get hands on a code from somebody, or also is convenient to browse your own projects. It includes functionality from such tools as: ctags, cscope and ctree, but it is faster than any of them, and is offering the features in one package. In some way it can be viewed as a superset of ctags, cscope and ctree. WWW: http://silentbob.sourceforge.net/ PR: 128969 Submitted by: TAKATSU Tomonari <tota at rtfm dot jp>
Diffstat (limited to 'devel/silentbob')
-rw-r--r--devel/silentbob/Makefile44
-rw-r--r--devel/silentbob/distinfo3
-rw-r--r--devel/silentbob/files/patch-Sblib.cxx11
-rw-r--r--devel/silentbob/files/patch-inline.h11
-rw-r--r--devel/silentbob/pkg-descr17
-rw-r--r--devel/silentbob/pkg-plist17
6 files changed, 103 insertions, 0 deletions
diff --git a/devel/silentbob/Makefile b/devel/silentbob/Makefile
new file mode 100644
index 000000000000..219d42c26f6b
--- /dev/null
+++ b/devel/silentbob/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: silentbob
+# Date created: 2008-11-13
+# Whom: TAKATSU Tomonari <tota@rtfm.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silentbob
+PORTVERSION= 1.7.3
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= tota@rtfm.jp
+COMMENT= Yet another sourcecode indexing tool
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+PORTDOCS= *
+MAN1= silent_bob.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/lib/silent_bob/|${PREFIX}/lib/silent_bob/|' \
+ ${WRKSRC}/src/init.cxx
+
+pre-configure:
+ ${CP} ${WRKSRC}/CMakeLists_bsd.txt ${WRKSRC}/CMakeLists.txt
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/silent_bob.1 ${MANPREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/lib/silent_bob
+.for f in editor grep perl perlpackages python ruby ruby_newclass
+ ${INSTALL_PROGRAM} ${WRKSRC}/libplugin_${f}.so ${PREFIX}/lib/silent_bob
+.endfor
+.for l in bob tags the_tt gc_indent bob_perl bob_python bob_ruby
+ ${LN} -s silent_bob ${PREFIX}/bin/${l}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/silentbob/distinfo b/devel/silentbob/distinfo
new file mode 100644
index 000000000000..76c6f0c71982
--- /dev/null
+++ b/devel/silentbob/distinfo
@@ -0,0 +1,3 @@
+MD5 (silentbob-1.7.3.tar.gz) = ae948ca0fd2e5a03093e88110a8ef923
+SHA256 (silentbob-1.7.3.tar.gz) = ef2a3fe08bf1c716c86400812d5f04816b2bcfd0afc6f250e753a1b5b614bfb1
+SIZE (silentbob-1.7.3.tar.gz) = 80357
diff --git a/devel/silentbob/files/patch-Sblib.cxx b/devel/silentbob/files/patch-Sblib.cxx
new file mode 100644
index 000000000000..0a6b8ff38158
--- /dev/null
+++ b/devel/silentbob/files/patch-Sblib.cxx
@@ -0,0 +1,11 @@
+--- sblib/Sblib.cxx.orig 2008-09-18 12:45:29.000000000 +0900
++++ sblib/Sblib.cxx 2008-11-13 15:53:16.000000000 +0900
+@@ -346,7 +346,7 @@
+ lseek (fd, 0, SEEK_END);
+ dup2 (devnull, 2);
+ dup2 (fd, 1);
+- execlp ("find", path, "-name", name, NULL);
++ execlp ("find", "find", path, "-name", name, NULL);
+ } else if (pid > 0) {
+ waitpid (pid, &status, 0);
+ return status;
diff --git a/devel/silentbob/files/patch-inline.h b/devel/silentbob/files/patch-inline.h
new file mode 100644
index 000000000000..bf569574f25a
--- /dev/null
+++ b/devel/silentbob/files/patch-inline.h
@@ -0,0 +1,11 @@
+--- include/inline.h.orig 2008-08-28 18:31:51.000000000 +0900
++++ include/inline.h 2008-11-13 15:53:51.000000000 +0900
+@@ -109,7 +109,7 @@
+ return count;
+ }
+
+-#define find_one_ext(ext) sblib_find ((char *) "./", (char *) ext, ENV->tmp_files)
++#define find_one_ext(ext) sblib_find ((char *) ".", (char *) ext, ENV->tmp_files)
+
+ #endif
+
diff --git a/devel/silentbob/pkg-descr b/devel/silentbob/pkg-descr
new file mode 100644
index 000000000000..e463940d4162
--- /dev/null
+++ b/devel/silentbob/pkg-descr
@@ -0,0 +1,17 @@
+"SilentBob" is a tool to help a programmer/team manager to digest
+and comprehend either a simple program or a big source code tree
+based on the source code by presenting the code in a searcheable
+and tagged way.
+
+It helps to speed up the learning curve and to make it more convenient
+to get hands on a code from somebody, or also is convenient to
+browse your own projects.
+
+It includes functionality from such tools as: ctags, cscope and
+ctree, but it is faster than any of them, and is offering the
+features in one package.
+
+In some way it can be viewed as a superset of ctags, cscope and
+ctree.
+
+WWW: http://silentbob.sourceforge.net/
diff --git a/devel/silentbob/pkg-plist b/devel/silentbob/pkg-plist
new file mode 100644
index 000000000000..55b1393f863d
--- /dev/null
+++ b/devel/silentbob/pkg-plist
@@ -0,0 +1,17 @@
+bin/bob
+bin/bob_perl
+bin/bob_python
+bin/bob_ruby
+bin/gc_indent
+bin/silent_bob
+bin/tags
+bin/the_tt
+lib/libsblib.so
+lib/silent_bob/libplugin_editor.so
+lib/silent_bob/libplugin_grep.so
+lib/silent_bob/libplugin_perl.so
+lib/silent_bob/libplugin_perlpackages.so
+lib/silent_bob/libplugin_python.so
+lib/silent_bob/libplugin_ruby.so
+lib/silent_bob/libplugin_ruby_newclass.so
+@dirrm lib/silent_bob