aboutsummaryrefslogtreecommitdiffstats
path: root/devel/spin/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-17 04:18:20 +0800
committerade <ade@FreeBSD.org>2000-09-17 04:18:20 +0800
commit4a7de36a939e9aeb43e17b54d76af4e513fb4f88 (patch)
tree2c94388c79de30c67f313fc32e162d06265117f8 /devel/spin/Makefile
parentf7c5f27ddd56fbc293bde952eddc09d19fd26b51 (diff)
downloadfreebsd-ports-gnome-4a7de36a939e9aeb43e17b54d76af4e513fb4f88.tar.gz
freebsd-ports-gnome-4a7de36a939e9aeb43e17b54d76af4e513fb4f88.tar.zst
freebsd-ports-gnome-4a7de36a939e9aeb43e17b54d76af4e513fb4f88.zip
Update to 3.4.1
PR: 21181 Submitted by: maintainer
Diffstat (limited to 'devel/spin/Makefile')
-rw-r--r--devel/spin/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index 9323a74dbf5a..3a4e7b1a4036 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= spin
-PORTVERSION= 3.3.10
+PORTVERSION= 3.4.1
CATEGORIES= math
MASTER_SITES= ftp://netlib.bell-labs.com/netlib/spin/ \
ftp://www.netlib.org/spin/ \
ftp://ftp.freesoftware.com/pub/netlib/spin/
-DISTFILES= spin3310.tar.gz html.tar.gz
+DISTFILES= spin341.tar.gz html.tar.gz
MAINTAINER= jhanna@home.com
DIST_SUBDIR= spin
-WRKSRC= ${WRKDIR}/Src3.3
+WRKSRC= ${WRKDIR}/Src3.4
MAKEFILE= makefile
ALL_TARGET= spin
@@ -24,16 +24,16 @@ post-extract:
@cd ${WRKDIR}/Test && ${SH} ${WRKDIR}/Test/examples
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKDIR}/Xspin3.3/xspin3310.tcl
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKDIR}/Xspin3.4/xspin341.tcl
pre-build:
cd ${WRKSRC} && ${MAKE} clean
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spin ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKDIR}/Xspin3.3/xspin3310.tcl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/Xspin3.4/xspin341.tcl ${PREFIX}/bin
${RM} -f ${PREFIX}/bin/xspin
- ${LN} -s ${PREFIX}/bin/xspin3310.tcl ${PREFIX}/bin/xspin
+ ${LN} -s ${PREFIX}/bin/xspin341.tcl ${PREFIX}/bin/xspin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/spin/Doc
@@ -44,7 +44,7 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/Test/ex.* ${PREFIX}/share/doc/spin/Examples
${INSTALL_DATA} ${WRKDIR}/HTML/* ${PREFIX}/share/doc/spin/HTML
.for i in README.tests abp erathostenes hello leader leader.ltl leader2 \
- loops pathfinder peterson petersonN pftp priorities snoopy sort
+ loops mobile1 mobile1.ltl mobile2 mobile2.ltl pathfinder peterson petersonN pftp priorities snoopy sort wordcount
${INSTALL_DATA} ${WRKDIR}/Test/$i ${PREFIX}/share/doc/spin/Test
.endfor
.endif