aboutsummaryrefslogtreecommitdiffstats
path: root/devel/swarm/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
committerasami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
commit7173d932bf0cf75d5bcbb04086481211381c60da (patch)
tree908d885d09e8b3286318f830430fb053fd31da00 /devel/swarm/Makefile
parentf963b9d59a81b7da6d33cb040282e1323af9a317 (diff)
downloadfreebsd-ports-gnome-7173d932bf0cf75d5bcbb04086481211381c60da.tar.gz
freebsd-ports-gnome-7173d932bf0cf75d5bcbb04086481211381c60da.tar.zst
freebsd-ports-gnome-7173d932bf0cf75d5bcbb04086481211381c60da.zip
(1) Add new variable, XFREE86_VERSION, to specify which version of
XFree86 (3 or 4) to depend to when USE_XLIB is set. XFREE86_VERSION defaults to 3 for now, but adventurous users can override it in /etc/make.conf. When XFREE86_VERSION=3, USE_XLIB will add a dependency to x11/XFree86; when it is set to 4, the dependency will be to x11/XFree86-4-libraries. When XFREE86_VERSION=4, the PKG_IGNORE_DEPENDS and ALWAYS_BUILD_DEPENDS hacks to avoid messing with XFree86 are turned off. Since XFree86 version 4 includes some software that used to be separate ports, when XFREE86_VERSION=3 the following variables are provided: USE_DGS LIB_DEPENDS on x11/dgs USE_FREETYPE LIB_DEPENDS on print/freetype USE_MESA LIB_DEPENDS on graphics/Mesa3 USE_XPM LIB_DEPENDS on graphics/xpm When XFREE86_VERSION=4, these variables have no effect. The LIB_DEPENDS in the tree for the above four ports have all been converted to the USE_* counterparts. For your information, this is the count of the number of ports: USE_DGS 0 USE_FREETYPE 16 USE_MESA 36 USE_XPM 236 There is a new variable, XAWVER, which is set to 6 when XFREE86_VERSION=3 and 7 when XFREE86_VERSION=4. This is also passed to PLIST_SUB so ports that build Xaw based shared libraries can use this variable to substitute the shlib version number. There is also a provision of using a separate mtree file for XFREE86_VERSION=4, but that part is not enabled yet. Reviewed by: the ports list Tested by: make index (XFREE86_VERSION=3 only) (2) Add hebrew to list of valid categories. Submitted by: nbm
Diffstat (limited to 'devel/swarm/Makefile')
-rw-r--r--devel/swarm/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/swarm/Makefile b/devel/swarm/Makefile
index b24291ddcd15..9c2376af2e1d 100644
--- a/devel/swarm/Makefile
+++ b/devel/swarm/Makefile
@@ -14,10 +14,10 @@ MAINTAINER= horance@freedom.ie.cycu.edu.tw
LIB_DEPENDS= ffi.2:${PORTSDIR}/devel/libffi \
png.4:${PORTSDIR}/graphics/png \
- Xpm.4:${PORTSDIR}/graphics/xpm \
BLT24.2:${PORTSDIR}/x11-toolkits/blt
USE_GMAKE= yes
+USE_XPM= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-defaultdir=${PREFIX} \