aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tcl-trf
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-06-25 05:05:39 +0800
committermi <mi@FreeBSD.org>2002-06-25 05:05:39 +0800
commitb88e39ed08119762bb9f2bad7d737ffc7d8fc5fa (patch)
treed77c4166e0f8eaf76d781c0579ae7ea1324cf439 /devel/tcl-trf
parentcf7bc934cc21b59f47200928ef6bae7141914d8c (diff)
downloadfreebsd-ports-gnome-b88e39ed08119762bb9f2bad7d737ffc7d8fc5fa.tar.gz
freebsd-ports-gnome-b88e39ed08119762bb9f2bad7d737ffc7d8fc5fa.tar.zst
freebsd-ports-gnome-b88e39ed08119762bb9f2bad7d737ffc7d8fc5fa.zip
PERL -> REINPLACE_CMD.
Diffstat (limited to 'devel/tcl-trf')
-rw-r--r--devel/tcl-trf/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index 4420a1239584..c1433bd8c25a 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -29,6 +29,8 @@ DDIR= ${PREFIX}/lib/tcl${TCL_VER}/Trf
MAKE_ENV+= TCL_VER=${TCL_VER} MKDIR="${MKDIR}" \
INSTALL_DATA="${INSTALL_DATA}"
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER} \
--with-tclinclude=${LOCALBASE}/include/tcl${TCL_VER} \
@@ -40,10 +42,10 @@ post-extract:
post-patch:
# Make direct calls to -lbz2
- ${PERL} -pi -e 's,bz\.([^(]+),BZ2_bz\u\1,g' \
+ ${REINPLACE_CMD} -e 's,bz\.([^(]+),BZ2_bz\u\1,g' \
${WRKSRC}/generic/bz2.c
# Make direct calls to -lz
- ${PERL} -pi -e 's,zf\.([^(]+),\1,g' ${WRKSRC}/generic/adler.c \
+ ${REINPLACE_CMD} -e 's,zf\.([^(]+),\1,g' ${WRKSRC}/generic/adler.c \
${WRKSRC}/generic/crc_zlib.c ${WRKSRC}/generic/zip.c
post-install: