aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tclxml/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-06-25 10:19:51 +0800
committerbeech <beech@FreeBSD.org>2008-06-25 10:19:51 +0800
commit664c415d42cd1db20b411134f782cf0514c69724 (patch)
tree2b3f5a71f829376747452321fc864e50397e6e9e /devel/tclxml/Makefile
parentb7758639a2da3aeefbfa22740fcfb31d14c1f23c (diff)
downloadfreebsd-ports-gnome-664c415d42cd1db20b411134f782cf0514c69724.tar.gz
freebsd-ports-gnome-664c415d42cd1db20b411134f782cf0514c69724.tar.zst
freebsd-ports-gnome-664c415d42cd1db20b411134f782cf0514c69724.zip
- Add docs and configure to respect NOPORTDOCS
PR: ports/124126 Submitted by: David Yeske <dyeske@gmail.com> (maintainer)
Diffstat (limited to 'devel/tclxml/Makefile')
-rw-r--r--devel/tclxml/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/tclxml/Makefile b/devel/tclxml/Makefile
index 1b8983d07bc5..a854724de8ed 100644
--- a/devel/tclxml/Makefile
+++ b/devel/tclxml/Makefile
@@ -16,6 +16,9 @@ COMMENT= API for parsing XML documents using Tcl
RUN_DEPENDS?= dtplite:${PORTSDIR}/devel/tcllib
+PORTDOCS= README.html html.xsl nroff.xsl tclxml.html tclxml.xml \
+ README.xml man.macros tcldoc-1.0.dtd tclxml.n txt.xsl
+
USE_TCL= 82+
GNU_CONFIGURE= yes
USE_LDCONFIG?= ${PREFIX}/lib/Tclxml${PORTVERSION}
@@ -25,4 +28,13 @@ PLIST= ${PKGDIR}${PKGNAMESUFFIX}/pkg-plist
PATCHDIR= ${PKGDIR}${PKGNAMESUFFIX}/files/
PLIST_SUB= VER=${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-install:
+
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>