aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tla
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-08-18 06:01:07 +0800
committerseanc <seanc@FreeBSD.org>2003-08-18 06:01:07 +0800
commit28463dc507a5821a961dd92ee8733cc9240df7c5 (patch)
tree67b746f45b8fbbe8616261e37c403d78c8d5e7d0 /devel/tla
parent49a483a688de9c4d733dccb237eb34e4ad7a83e3 (diff)
downloadfreebsd-ports-gnome-28463dc507a5821a961dd92ee8733cc9240df7c5.tar.gz
freebsd-ports-gnome-28463dc507a5821a961dd92ee8733cc9240df7c5.tar.zst
freebsd-ports-gnome-28463dc507a5821a961dd92ee8733cc9240df7c5.zip
Add tla, an arch CLI written in C.
Arch is a really nifty revision control system. It's "whole-tree changeset based" which means, roughly, that it can handle (with atomic commits) file and directory adds, deletes, and renames cleanly, and that it does branching simply and easily. Arch is also "distributed" which means, for example that you can make arch branches of your own from remote projects, even if you don't have write access to the revision control archives for those projects. This looks to be as close to an open source p4 replacement as one could hope without being p4. I'll go so far as to suggest that if this SCM was employed by the BSD crowd, merging changes between dragonfly (post source repo reorog), NetBSD, and OpenBSD would be radically less painful. It is very possible that the dragonfly fork may not have happened under the arch SCM development methodology, but if it did, at the very least it would be possible to incorporate dillion's reorg work in a single patch set, no cvs admin repo surgery needed. WWW: http://arch.fifthvision.net/bin/view
Diffstat (limited to 'devel/tla')
-rw-r--r--devel/tla/Makefile42
-rw-r--r--devel/tla/distinfo1
-rw-r--r--devel/tla/pkg-descr9
-rw-r--r--devel/tla/pkg-plist2
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/tla/Makefile b/devel/tla/Makefile
new file mode 100644
index 000000000000..132670cc4f9e
--- /dev/null
+++ b/devel/tla/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: tla
+# Date Created: August 17th, 2003
+# Whom: seanc
+#
+# $FreeBSD$
+#
+
+PORTNAME= tla
+PORTVERSION= 1.1.pre5
+CATEGORIES= devel
+MASTER_SITES= http://regexps.srparish.net/src/tla/
+DISTNAME= tla-1.1pre5
+
+MAINTAINER= seanc@FreeBSD.org
+COMMENT= The original arch source control management CLI written in C
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+ORIGWRKSRC= ${WRKDIR}/${DISTNAME}/src
+WRKSRC= ${ORIGWRKSRC}/=build
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}
+
+do-configure:
+ cd ${WRKSRC} ; ../configure --prefix ${LOCALBASE}
+
+test:
+ cd ${WRKSRC} ; ${GMAKE} test
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}; \
+ for f in `find ${ORIGWRKSRC}/docs-tla/html -type f -name '*.html' -exec ${BASENAME} {} \;`; do \
+ ${INSTALL_DATA} ${ORIGWRKSRC}/docs-tla/html/$$f ${DOCSDIR}/; \
+ printf "share/doc/${PORTNAME}/%s\n" $$f >> ${TMPPLIST}; \
+ done; \
+ ${ECHO} @dirrm share/doc/${PORTNAME} >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/tla/distinfo b/devel/tla/distinfo
new file mode 100644
index 000000000000..23bfb5a8722e
--- /dev/null
+++ b/devel/tla/distinfo
@@ -0,0 +1 @@
+MD5 (tla-1.1pre5.tar.gz) = 16512739150bdb81764a9d2fffb6a423
diff --git a/devel/tla/pkg-descr b/devel/tla/pkg-descr
new file mode 100644
index 000000000000..f04a44f5469c
--- /dev/null
+++ b/devel/tla/pkg-descr
@@ -0,0 +1,9 @@
+Arch is a really nifty revision control system. It's "whole-tree
+changeset based" which means, roughly, that it can handle (with atomic
+commits) file and directory adds, deletes, and renames cleanly, and
+that it does branching simply and easily. Arch is also "distributed"
+which means, for example that you can make arch branches of your own
+from remote projects, even if you don't have write access to the
+revision control archives for those projects.
+
+WWW: http://arch.fifthvision.net/bin/view
diff --git a/devel/tla/pkg-plist b/devel/tla/pkg-plist
new file mode 100644
index 000000000000..0465aaa9d0c5
--- /dev/null
+++ b/devel/tla/pkg-plist
@@ -0,0 +1,2 @@
+bin/tla
+@comment automatically generated plist for docs