aboutsummaryrefslogtreecommitdiffstats
path: root/devel/upnp104/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-04-14 10:05:22 +0800
committerleeym <leeym@FreeBSD.org>2003-04-14 10:05:22 +0800
commitb30e20bb96f267c3209a0830ff44a7251fc67ba0 (patch)
treecc357ad87eff36f40aa7a69ec4e37ee6e1863d1a /devel/upnp104/Makefile
parentaa1b50a749a7ab8627e5b0e86cb199c573d43d04 (diff)
downloadfreebsd-ports-gnome-b30e20bb96f267c3209a0830ff44a7251fc67ba0.tar.gz
freebsd-ports-gnome-b30e20bb96f267c3209a0830ff44a7251fc67ba0.tar.zst
freebsd-ports-gnome-b30e20bb96f267c3209a0830ff44a7251fc67ba0.zip
Backout previous commit.
It's a incompatible upgrade; net/linuxigd isn't yet ready for it. Noticed by: kris & bento, and many other linuxigd users.
Diffstat (limited to 'devel/upnp104/Makefile')
-rw-r--r--devel/upnp104/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/devel/upnp104/Makefile b/devel/upnp104/Makefile
index ca730773f13c..e504fa969059 100644
--- a/devel/upnp104/Makefile
+++ b/devel/upnp104/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= upnp
-PORTVERSION= 1.2.1
+PORTVERSION= 1.0.4
+PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= lib${PORTNAME}-${PORTVERSION}
+DISTNAME= ${PORTNAME}sdk-${PORTVERSION}
MAINTAINER= leeym@FreeBSD.org
COMMENT= Universal Plug and Play Software Development Kit
@@ -19,22 +20,22 @@ LIB_DEPENDS= uuid.1:${PORTSDIR}/sysutils/e2fsprogs
USE_GMAKE= yes
USE_REINPLACE= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/upnp
-PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
MAKEFILE= makefile
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
NOT_FOR_ARCHS= sparc64
INSTALLS_SHLIB= yes
post-patch:
- @${FIND} ${PATCH_WRKSRC} -name "*.[ch]" | \
- ${XARGS} ${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,'
- @${FIND} ${PATCH_WRKSRC} -name "[Mm]akefile" | ${XARGS} ${REINPLACE_CMD} \
- -e 's,lpthread,pthread, ; s,/usr,,g ; s,1\.2\.1,1,g' \
- -e 's,MAKE = make,MAKE = ${GMAKE},' \
- -e 's,install bin,${INSTALL_PROGRAM} bin,g' \
- -e 's,install inc,${INSTALL_DATA} inc,g'
- @${REINPLACE_CMD} -e 's,MSG_NOSIGNAL,0,' ${PATCH_WRKSRC}/upnp/src/genlib/net/sock.c
- @${REINPLACE_CMD} -e 's,linux/if,net/if,' ${PATCH_WRKSRC}/upnp/src/api/upnpapi.c
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,MAKE = make,MAKE = ${GMAKE},' \
+ src/genlib/makefile src/makefile
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' \
+ src/inc/genlib/client_table/client_table.h \
+ src/inc/genlib/http_client/http_client.h \
+ src/inc/genlib/service_table/service_table.h \
+ src/inc/genlib/timer_thread/timer_thread.h \
+ src/upnpdom/domCif.cpp
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,MSG_NOSIGNAL,0,' \
+ src/genlib/http_client/http_client.c \
+ src/genlib/net/http/readwrite.cpp
.include <bsd.port.mk>