aboutsummaryrefslogtreecommitdiffstats
path: root/devel/valgrind-snapshot
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-08-11 21:26:20 +0800
committerbarner <barner@FreeBSD.org>2005-08-11 21:26:20 +0800
commit3f5aa1dc783b5797a873867f8fe0b822ae5c5da8 (patch)
treeb9a844220a86e0b3f05157c443e5fbfde2b86889 /devel/valgrind-snapshot
parent9b3e5c861d73fc38aa2679f1199709c98314d5eb (diff)
downloadfreebsd-ports-gnome-3f5aa1dc783b5797a873867f8fe0b822ae5c5da8.tar.gz
freebsd-ports-gnome-3f5aa1dc783b5797a873867f8fe0b822ae5c5da8.tar.zst
freebsd-ports-gnome-3f5aa1dc783b5797a873867f8fe0b822ae5c5da8.zip
- Mark valgrind ports IGNORE when /proc is not mounted, previously, only
a warning was printed. A mounted procfs is a runtime dependency of valgrind, but since the implementation of automatic suppression file generation the valgrind binary is run in the post-install stage. - An exception needs to be made for the ports cluster: The machine compiling the list of IGNOREd ports does not have a mounted /proc, so the check (and the generation of supression files is disabled there). Users who want to suppress false positives in valgrinds output should build the port instead of installing the package (so the rules can be customized to their specific installation). Reported by: Paul Ledbetter III <aeacides@gmail.com> Approved by: portmgr (kris)
Diffstat (limited to 'devel/valgrind-snapshot')
-rw-r--r--devel/valgrind-snapshot/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/devel/valgrind-snapshot/Makefile b/devel/valgrind-snapshot/Makefile
index 2118d841834c..9e280c1ba946 100644
--- a/devel/valgrind-snapshot/Makefile
+++ b/devel/valgrind-snapshot/Makefile
@@ -52,15 +52,20 @@ pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "Check if procfs is running: YES"
.else
- @${ECHO_CMD} "-----------------------------------------------------------"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "Valgrind needs a running procfs, which is not"
- @${ECHO_CMD} "activated on your system. Please read the procfs\(5\)"
- @${ECHO_CMD} "manpage and add the following line to /etc/fstab:"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "proc /proc procfs rw 0 0"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "-----------------------------------------------------------"
+#
+# /proc is not mounted on the machine in the package building cluster that
+# that builds the list of IGNOREd ports (but it is on the build machines),
+# so we need to make an exception here.
+#
+.ifndef (PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= needs a running procfs, which is not\n\
+\ \ \ \ \ activated on your system. Please read the procfs\(5\)\n\
+\ \ \ \ \ man page and add the following line to /etc/fstab:\n\
+\n\
+\ \ \ \ \ proc /proc procfs rw 0 0\n\
+\n
+.endif
.endif
pre-patch:
@@ -84,11 +89,13 @@ post-install:
.endif
# Generate suppression files
+.ifndef (PACKAGE_BUILDING)
@yes | ${PREFIX}/bin/valgrind --tool=memcheck --gen-suppressions=yes true 2>&1 \
| ${SED} -e 's,.*{$$,{,' \
| ${GREP} -v '^=' \
> ${WRKDIR}/freebsd-default.supp || \
${RM} ${WRKDIR}/freebsd-default.supp
+.endif
.if exists(${WRKDIR}/freebsd-default.supp)
@${INSTALL_DATA} ${WRKDIR}/freebsd-default.supp \