aboutsummaryrefslogtreecommitdiffstats
path: root/devel/vera++
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /devel/vera++
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'devel/vera++')
-rw-r--r--devel/vera++/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/vera++/Makefile b/devel/vera++/Makefile
index 89a38f1c44d3..9e223b761edb 100644
--- a/devel/vera++/Makefile
+++ b/devel/vera++/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs
-USES= compiler:c++11-lang cmake:outsource tk
+USES= compiler:c++11-lang cmake tk
CMAKE_ARGS+= -DTCL_INCLUDE_PATH=${TCL_INCLUDEDIR} \
-DTK_INCLUDE_PATH=${TK_INCLUDEDIR} \