aboutsummaryrefslogtreecommitdiffstats
path: root/devel/vtcl
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
committermarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
commit71ad4933995cc892d62e378ee5be6ac15c6e62ef (patch)
tree610711606eefa728d01e4e333cc0119ea924f1f6 /devel/vtcl
parent8918e3de46086cf18a356130171394cc05affdc3 (diff)
downloadfreebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.gz
freebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.zst
freebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.zip
unPERLify, and use ${FIND} and ${XARGS} where appropriate.
PR: 48253 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'devel/vtcl')
-rw-r--r--devel/vtcl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/vtcl/Makefile b/devel/vtcl/Makefile
index 7469eaf7e020..e92a8ca7994e 100644
--- a/devel/vtcl/Makefile
+++ b/devel/vtcl/Makefile
@@ -20,8 +20,10 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= ${PREFIX}
NO_BUILD= yes
+USE_REINPLACE= yes
+
pre-configure:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/configure
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/vtcl ${PREFIX}/bin