aboutsummaryrefslogtreecommitdiffstats
path: root/devel/xmake
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-07-06 20:30:31 +0800
committerpawel <pawel@FreeBSD.org>2014-07-06 20:30:31 +0800
commitf51dee27da16db2159b6cef141bd8c99c94bf97c (patch)
tree4ff0051007c0f365b8ff404d3a0b8ebef8cf9dc5 /devel/xmake
parent343f5009af5d6cbeaa40a88d83b014f968c8084e (diff)
downloadfreebsd-ports-gnome-f51dee27da16db2159b6cef141bd8c99c94bf97c.tar.gz
freebsd-ports-gnome-f51dee27da16db2159b6cef141bd8c99c94bf97c.tar.zst
freebsd-ports-gnome-f51dee27da16db2159b6cef141bd8c99c94bf97c.zip
Don't hardcode gcc in xmake binary
Diffstat (limited to 'devel/xmake')
-rw-r--r--devel/xmake/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/xmake/Makefile b/devel/xmake/Makefile
index eb7a44a519a5..d822a58d1252 100644
--- a/devel/xmake/Makefile
+++ b/devel/xmake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmake
PORTVERSION= 1.06
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://apollo.backplane.com/xmake/
EXTRACT_SUFX= .tgz
@@ -16,4 +17,7 @@ PLIST_FILES= bin/xmake man/man1/xmake.1.gz
post-extract:
@${RM} -rf ${WRKSRC}/obj
+post-patch:
+ @${REINPLACE_CMD} 's|gcc|cc|' ${WRKSRC}/defs.h
+
.include <bsd.port.mk>