aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-24 03:47:54 +0800
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-24 03:47:54 +0800
commit010ac84292926468b9a4041183a8230f6eb1f2ac (patch)
tree6122864dd945e58c2610dcff369e98a9e23d1ff6 /devel
parentc32d17775a6d5e1b48d6ec056b2f9f8a54950b59 (diff)
downloadfreebsd-ports-gnome-010ac84292926468b9a4041183a8230f6eb1f2ac.tar.gz
freebsd-ports-gnome-010ac84292926468b9a4041183a8230f6eb1f2ac.tar.zst
freebsd-ports-gnome-010ac84292926468b9a4041183a8230f6eb1f2ac.zip
Add devel/utf8cpp.
utf8cpp is a C++ library for handling UTF-8 strings. It is also a requirement for updating finance/ledger. PR: 191297 Submitted by: Keith Gaughan <k@stereochro.me>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/utf8cpp/Makefile28
-rw-r--r--devel/utf8cpp/distinfo2
-rw-r--r--devel/utf8cpp/pkg-descr14
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 99dbab96b336..c40318939025 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4643,6 +4643,7 @@
SUBDIR += upslug
SUBDIR += urjtag
SUBDIR += ustl
+ SUBDIR += utf8cpp
SUBDIR += uthash
SUBDIR += valgrind
SUBDIR += valgrind-devel
diff --git a/devel/utf8cpp/Makefile b/devel/utf8cpp/Makefile
new file mode 100644
index 000000000000..9dd53ee90a4a
--- /dev/null
+++ b/devel/utf8cpp/Makefile
@@ -0,0 +1,28 @@
+# Created by: Keith Gaughan <k@stereochro.me>
+# $FreeBSD$
+
+PORTNAME= utf8cpp
+PORTVERSION= 2.3.4
+CATEGORIES= textproc
+MASTER_SITES= SF/utfcpp/${PORTNAME:tl}_2x/Release%20${PORTVERSION}/
+DISTNAME= utf8_v${PORTVERSION:S/./_/g}
+
+MAINTAINER= k@stereochro.me
+COMMENT= Simple, portable, lightweight library for handling UTF-8 strings
+
+LICENSE= BSL
+
+USES= zip
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= include/utf8.h \
+ include/utf8/checked.h \
+ include/utf8/core.h \
+ include/utf8/unchecked.h
+PLIST_DIRS= include/utf8
+
+do-install:
+ (cd ${WRKSRC}/source; ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include)
+
+.include <bsd.port.mk>
diff --git a/devel/utf8cpp/distinfo b/devel/utf8cpp/distinfo
new file mode 100644
index 000000000000..33abdb1b7ded
--- /dev/null
+++ b/devel/utf8cpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (utf8_v2_3_4.zip) = 3373cebb25d88c662a2b960c4d585daf9ae7b396031ecd786e7bb31b15d010ef
+SIZE (utf8_v2_3_4.zip) = 22422
diff --git a/devel/utf8cpp/pkg-descr b/devel/utf8cpp/pkg-descr
new file mode 100644
index 000000000000..652aab866632
--- /dev/null
+++ b/devel/utf8cpp/pkg-descr
@@ -0,0 +1,14 @@
+Many C++ developers miss an easy and portable way of handling Unicode
+encoded strings. The original C++ Standard (known as C++98 or C++03) is
+Unicode agnostic. C++11 provides some support for Unicode on core
+language and library level: u8, u, and U character and string literals,
+char16_t and char32_t character types, u16string and u32string library
+classes, and codecvt support for conversions between Unicode encoding
+forms. In the meantime, developers use third party libraries like ICU,
+OS specific capabilities, or simply roll out their own solutions.
+
+In order to easily handle UTF-8 encoded Unicode strings, I came up with
+a small generic library. For anybody used to work with STL algorithms
+and iterators, it should be easy and natural to use.
+
+WWW: http://utfcpp.sourceforge.net/