aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-08-23 14:30:29 +0800
committerkoobs <koobs@FreeBSD.org>2014-08-23 14:30:29 +0800
commit014a26740d45e955eee2266aa2dbee206759e5de (patch)
tree769d0be384ea7a8f5dfd01effc985c22e56f3b7a /devel
parent654afbcb3f18b3dd19e7e63ebf69d652a271b403 (diff)
downloadfreebsd-ports-gnome-014a26740d45e955eee2266aa2dbee206759e5de.tar.gz
freebsd-ports-gnome-014a26740d45e955eee2266aa2dbee206759e5de.tar.zst
freebsd-ports-gnome-014a26740d45e955eee2266aa2dbee206759e5de.zip
devel/picosat: Satisfiability (SAT) solver for boolean variables
PicoSAT is a satisfiability (SAT) solver for boolean variables in boolean expressions. A SAT solver can determine if it is possible to find assignments to boolean variables that would make a given set of expressions true. If it's satisfiable, it can also show a set of assignments that make the expression true. Many problems can be broken down into a large SAT problem (perhaps with thousands of variables), so SAT solvers have a variety of uses. WWW: http://fmv.jku.at/picosat
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/picosat/Makefile30
-rw-r--r--devel/picosat/distinfo2
-rw-r--r--devel/picosat/pkg-descr10
-rw-r--r--devel/picosat/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 03eb67ada1e0..da68b9cd3e1e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3462,6 +3462,7 @@
SUBDIR += phptags
SUBDIR += physfs
SUBDIR += physfs-devel
+ SUBDIR += picosat
SUBDIR += picp
SUBDIR += picprog
SUBDIR += piklab
diff --git a/devel/picosat/Makefile b/devel/picosat/Makefile
new file mode 100644
index 000000000000..634a5261b961
--- /dev/null
+++ b/devel/picosat/Makefile
@@ -0,0 +1,30 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= picosat
+DISTVERSION= 957
+CATEGORIES= devel math
+MASTER_SITES= http://fmv.jku.at/picosat/
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Satisfiability (SAT) solver for boolean variables
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_LDCONFIG= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --shared --trace --stats
+MAKEFILE= makefile
+MAKE_JOBS_UNSAFE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/picosat ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picomcs ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picomus ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picogcnf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_LIB} ${WRKSRC}/libpicosat.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libpicosat.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/picosat.h ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/devel/picosat/distinfo b/devel/picosat/distinfo
new file mode 100644
index 000000000000..cfa08da26d36
--- /dev/null
+++ b/devel/picosat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (picosat-957.tar.gz) = 7efa0149f297971328324b90cee349223e3c9c9aab6f6e306caae2553a169822
+SIZE (picosat-957.tar.gz) = 63329
diff --git a/devel/picosat/pkg-descr b/devel/picosat/pkg-descr
new file mode 100644
index 000000000000..4b53b22143b8
--- /dev/null
+++ b/devel/picosat/pkg-descr
@@ -0,0 +1,10 @@
+PicoSAT is a satisfiability (SAT) solver for boolean variables in
+boolean expressions. A SAT solver can determine if it is possible to
+find assignments to boolean variables that would make a given set of
+expressions true. If it's satisfiable, it can also show a set of
+assignments that make the expression true.
+
+Many problems can be broken down into a large SAT problem (perhaps with
+thousands of variables), so SAT solvers have a variety of uses.
+
+WWW: http://fmv.jku.at/picosat
diff --git a/devel/picosat/pkg-plist b/devel/picosat/pkg-plist
new file mode 100644
index 000000000000..75683008eba2
--- /dev/null
+++ b/devel/picosat/pkg-plist
@@ -0,0 +1,7 @@
+bin/picogcnf
+bin/picomcs
+bin/picomus
+bin/picosat
+include/picosat.h
+lib/libpicosat.a
+lib/libpicosat.so