aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-06-10 02:39:28 +0800
committerobraun <obraun@FreeBSD.org>2003-06-10 02:39:28 +0800
commit020484ea120904268c9e597d6074be555f44b62d (patch)
tree70d4e74db1b51dab591e3fbce4521d18f91d3977 /devel
parent7a371b71971b67aff385b0396bb50cb7db418105 (diff)
downloadfreebsd-ports-gnome-020484ea120904268c9e597d6074be555f44b62d.tar.gz
freebsd-ports-gnome-020484ea120904268c9e597d6074be555f44b62d.tar.zst
freebsd-ports-gnome-020484ea120904268c9e597d6074be555f44b62d.zip
Remove ghc's package.conf.old.
Pointed out by: kris, bento
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-c2hs/Makefile5
-rw-r--r--devel/hs-c2hs/pkg-plist2
2 files changed, 6 insertions, 1 deletions
diff --git a/devel/hs-c2hs/Makefile b/devel/hs-c2hs/Makefile
index 9f3c2ea8c69c..0b1166415f1a 100644
--- a/devel/hs-c2hs/Makefile
+++ b/devel/hs-c2hs/Makefile
@@ -20,7 +20,9 @@ RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
HAS_CONFIGURE= yes
USE_GMAKE= yes
-PLIST_SUB= C2HS_VERSION=${PORTVERSION}
+GHC_VERSION= `${PREFIX}/bin/ghc --version 2>&1 | \
+ ${SED} 's/^.*version[ ]*\([0-9.]*\).*/\1/'`
+PLIST_SUB+= C2HS_VERSION="${PORTVERSION}" GHC_VERSION="${GHC_VERSION}"
CONFIGURE_ARGS+= --prefix=${PREFIX} --enable-add-package
@@ -42,5 +44,6 @@ post-build:
post-install:
@(cd ${WRKSRC}/doc/c2hs/man1 && \
${INSTALL_MAN} c2hs-config.1 c2hs.1 ${MANPREFIX}/man/man1)
+ @${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
.include <bsd.port.mk>
diff --git a/devel/hs-c2hs/pkg-plist b/devel/hs-c2hs/pkg-plist
index a3e152b539d3..c9536ba77d2f 100644
--- a/devel/hs-c2hs/pkg-plist
+++ b/devel/hs-c2hs/pkg-plist
@@ -13,4 +13,6 @@ lib/c2hs-%%C2HS_VERSION%%/ghc5/c2hs.o
@dirrm lib/c2hs-%%C2HS_VERSION%%/ghc5
@dirrm lib/c2hs-%%C2HS_VERSION%%
@exec %D/bin/c2hs-config --package-conf | %D/bin/ghc-pkg -u -g
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
@unexec %D/bin/ghc-pkg -r c2hs
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old