aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-03-20 01:28:51 +0800
committerBoris Samorodov <bsam@FreeBSD.org>2009-03-20 01:28:51 +0800
commit0263b9d868256500eb3f31df4c5a81d85d5389c8 (patch)
treebd3ef2dd232584e45f6077260b986d8a61cd6944 /devel
parente2ebded775e715fcec035ce1d61b9a2ba5fe6e17 (diff)
downloadfreebsd-ports-gnome-0263b9d868256500eb3f31df4c5a81d85d5389c8.tar.gz
freebsd-ports-gnome-0263b9d868256500eb3f31df4c5a81d85d5389c8.tar.zst
freebsd-ports-gnome-0263b9d868256500eb3f31df4c5a81d85d5389c8.zip
Welcome to the new linux ports infrastructure which allows using
both current (fc4) and future linux (f8) distributions at one ports tree. The patch contains full changes to ports/Mk files and all ports involved. But only infrastructure is changed. The resulting packages are the same as before. Hence no need to bump PORTREVISIONs. The idea was taken from bsd.gnome.mk and others. More than 130 ports are switched to follow a new linux infrastructure introduced by changes to bsd.port.mk, bsd.linux-rpm.mk and a new bsd.linux-apps.mk. Thanks for all who was involved and helped me with this work. And help from Alexander Leidinger was incredible. Other changes are coming. Stay tuned! PR: ports/132510 Submitted by: bsam (me) Exp-run by: portmgr (pav)
Diffstat (limited to 'devel')
-rw-r--r--devel/linux-allegro/Makefile2
-rw-r--r--devel/linux-f10-allegro/Makefile2
-rw-r--r--devel/linux-f10-sdl12/Makefile2
-rw-r--r--devel/linux-f8-allegro/Makefile2
-rw-r--r--devel/linux-f8-sdl12/Makefile2
-rw-r--r--devel/linux-runrev/Makefile2
-rw-r--r--devel/linux-sdl12/Makefile2
-rw-r--r--devel/radrails/Makefile4
8 files changed, 9 insertions, 9 deletions
diff --git a/devel/linux-allegro/Makefile b/devel/linux-allegro/Makefile
index aecaafecf585..b855c36a7ad4 100644
--- a/devel/linux-allegro/Makefile
+++ b/devel/linux-allegro/Makefile
@@ -16,10 +16,10 @@ MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Cross-platform game programming library (linux version)
USE_LINUX_RPM= yes
+USE_LINUX_APPS= xorglibs
ONLY_FOR_ARCHS= i386 amd64
DIST_SUBDIR= rpm
USE_LDCONFIG= yes
-USE_XLIB= yes
SRC_DISTFILES=
MD5_FILE= ${MASTERDIR}/distinfo
diff --git a/devel/linux-f10-allegro/Makefile b/devel/linux-f10-allegro/Makefile
index aecaafecf585..b855c36a7ad4 100644
--- a/devel/linux-f10-allegro/Makefile
+++ b/devel/linux-f10-allegro/Makefile
@@ -16,10 +16,10 @@ MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Cross-platform game programming library (linux version)
USE_LINUX_RPM= yes
+USE_LINUX_APPS= xorglibs
ONLY_FOR_ARCHS= i386 amd64
DIST_SUBDIR= rpm
USE_LDCONFIG= yes
-USE_XLIB= yes
SRC_DISTFILES=
MD5_FILE= ${MASTERDIR}/distinfo
diff --git a/devel/linux-f10-sdl12/Makefile b/devel/linux-f10-sdl12/Makefile
index fc353658bcf8..ec312f529c75 100644
--- a/devel/linux-f10-sdl12/Makefile
+++ b/devel/linux-f10-sdl12/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Cross-platform multi-media development API (linux version)
USE_LINUX_RPM= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
INSTALL_SHLIB= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/devel/linux-f8-allegro/Makefile b/devel/linux-f8-allegro/Makefile
index aecaafecf585..b855c36a7ad4 100644
--- a/devel/linux-f8-allegro/Makefile
+++ b/devel/linux-f8-allegro/Makefile
@@ -16,10 +16,10 @@ MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Cross-platform game programming library (linux version)
USE_LINUX_RPM= yes
+USE_LINUX_APPS= xorglibs
ONLY_FOR_ARCHS= i386 amd64
DIST_SUBDIR= rpm
USE_LDCONFIG= yes
-USE_XLIB= yes
SRC_DISTFILES=
MD5_FILE= ${MASTERDIR}/distinfo
diff --git a/devel/linux-f8-sdl12/Makefile b/devel/linux-f8-sdl12/Makefile
index fc353658bcf8..ec312f529c75 100644
--- a/devel/linux-f8-sdl12/Makefile
+++ b/devel/linux-f8-sdl12/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Cross-platform multi-media development API (linux version)
USE_LINUX_RPM= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
INSTALL_SHLIB= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/devel/linux-runrev/Makefile b/devel/linux-runrev/Makefile
index b41f844d51fd..6629d6ee1048 100644
--- a/devel/linux-runrev/Makefile
+++ b/devel/linux-runrev/Makefile
@@ -25,7 +25,7 @@ NO_CDROM= "Sale for profit is not permitted"
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
WRKSRC= ${WRKDIR}/Revolution-${PORTVERSION}
DATADIR= ${PREFIX}/share/Revolution-${PORTVERSION}
diff --git a/devel/linux-sdl12/Makefile b/devel/linux-sdl12/Makefile
index fc353658bcf8..ec312f529c75 100644
--- a/devel/linux-sdl12/Makefile
+++ b/devel/linux-sdl12/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Cross-platform multi-media development API (linux version)
USE_LINUX_RPM= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
INSTALL_SHLIB= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/devel/radrails/Makefile b/devel/radrails/Makefile
index bd95425d560a..393341dc1348 100644
--- a/devel/radrails/Makefile
+++ b/devel/radrails/Makefile
@@ -15,14 +15,14 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-linux-gtk
MAINTAINER= alecn2002@yandex.ru
COMMENT= IDE for Ruby On Rails
-RUN_DEPENDS= ${LINUXBASE}/usr/bin/gtk-demo:${PORTSDIR}/x11-toolkits/linux-gtk2 \
- ${LOCALBASE}/bin/rails:${PORTSDIR}/www/rubygem-rails
+RUN_DEPENDS= ${LOCALBASE}/bin/rails:${PORTSDIR}/www/rubygem-rails
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
+USE_LINUX_APPS= gtk2
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_OS= linux