aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-06-05 19:59:16 +0800
committerpgj <pgj@FreeBSD.org>2009-06-05 19:59:16 +0800
commit02b996c79ec73b24bfa6cc64ffa0b9acc803c38d (patch)
tree79259dfb2fed0b2296c4e2be1a1eeb24c704f1aa /devel
parent00949ae2591985986a3b1a4c515edffba5fd1454 (diff)
downloadfreebsd-ports-gnome-02b996c79ec73b24bfa6cc64ffa0b9acc803c38d.tar.gz
freebsd-ports-gnome-02b996c79ec73b24bfa6cc64ffa0b9acc803c38d.tar.zst
freebsd-ports-gnome-02b996c79ec73b24bfa6cc64ffa0b9acc803c38d.zip
- Respect custom PREFIX, LOCALBASE
- Bump port revision Reported by: QAT Approved by: gabor (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-alex/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/hs-alex/Makefile b/devel/hs-alex/Makefile
index 0b47cae175b3..ab4bc067650f 100644
--- a/devel/hs-alex/Makefile
+++ b/devel/hs-alex/Makefile
@@ -6,6 +6,7 @@
PORTNAME= alex
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/alex/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -14,9 +15,11 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= Alex is a tool for generating lexical analysers in Haskell
BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= ${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl \
${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt
+
PLIST_SUB+= RMLIC="@comment "
.else
PLIST_SUB+= RMLIC=""
@@ -32,6 +35,10 @@ PORTDOCS= LICENSE html
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
PORTEXAMPLES= *
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/share/xsl/docbook|${LOCALBASE}/share/xsl/docbook|' \
+ ${WRKSRC}/doc/configure.ac
+
do-configure:
cd ${WRKSRC} && runhaskell Setup.lhs configure ${CONFIGURE_ARGS}
cd ${WRKSRC}/doc && ${AUTOCONF} && ./configure --prefix=${PREFIX}