aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-10-13 03:40:05 +0800
committermarcus <marcus@FreeBSD.org>2004-10-13 03:40:05 +0800
commit0447e5f0efd8003c443a3f400ceafcf15468845a (patch)
tree219a66232c32382d259846845acc41ad88811089 /devel
parent8e20cfe07112c821db093765d60afe1a33080f11 (diff)
downloadfreebsd-ports-gnome-0447e5f0efd8003c443a3f400ceafcf15468845a.tar.gz
freebsd-ports-gnome-0447e5f0efd8003c443a3f400ceafcf15468845a.tar.zst
freebsd-ports-gnome-0447e5f0efd8003c443a3f400ceafcf15468845a.zip
Support .ifndef and !defined when doing OPTIONS checking.
Diffstat (limited to 'devel')
-rw-r--r--devel/portlint/Makefile1
-rw-r--r--devel/portlint/src/portlint.pl2
2 files changed, 2 insertions, 1 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index b02339f4fa6f..8e68e6905be5 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -9,6 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.6.8
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index 1e8a1206b937..25bfa1a2973d 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -2331,7 +2331,7 @@ FETCH_DEPENDS DEPENDS DEPENDS_TARGET
# check OPTIONS
print "OK: checking OPTIONS.\n" if ($verbose);
@oopt = ($makevar{OPTIONS} =~ /(\w+)\s+\".*?\"\s+\w+/sg);
- @mopt = ($tmp =~ /^\s*\.\s*(?:ifdef\s+|if\s+defined\s*)\(?\s*WITH(?:OUT)?_(\w+)\s*\)?/mg);
+ @mopt = ($tmp =~ /^\s*\.\s*(?:ifn?def\s+|if\s+\!?\s*defined\s*)\(?\s*WITH(?:OUT)?_(\w+)\s*\)?/mg);
foreach my $i (@oopt) {
if (!grep(/^$i$/, @mopt)) {
&perror("WARN: $file: $i is listed in OPTIONS, ".