aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-11-02 00:48:14 +0800
committerswills <swills@FreeBSD.org>2016-11-02 00:48:14 +0800
commit054dcf343db59257ccabf97b3b1bef022d7330a8 (patch)
tree853aefbc31cc6f2349fe1b391d80b9f0ba7924ff /devel
parentb2b0a71a7b80f2ed9039bff226a9c9a0ddb18b9e (diff)
downloadfreebsd-ports-gnome-054dcf343db59257ccabf97b3b1bef022d7330a8.tar.gz
freebsd-ports-gnome-054dcf343db59257ccabf97b3b1bef022d7330a8.tar.zst
freebsd-ports-gnome-054dcf343db59257ccabf97b3b1bef022d7330a8.zip
devel/rubygem-micromachine: create port
There are many finite state machine implementations for Ruby, and they all provide a nice DSL for declaring events, exceptions, callbacks, and all kinds of niceties in general. But if all you want is a finite state machine, look no further: this has less than 50 lines of code and provides everything a finite state machine must have, and nothing more. WWW: http://github.com/soveran/micromachine
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-micromachine/Makefile14
-rw-r--r--devel/rubygem-micromachine/distinfo3
-rw-r--r--devel/rubygem-micromachine/pkg-descr9
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 339ef800d670..7b8e9c9fffe7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5142,6 +5142,7 @@
SUBDIR += rubygem-metaid
SUBDIR += rubygem-metasm
SUBDIR += rubygem-method_source
+ SUBDIR += rubygem-micromachine
SUBDIR += rubygem-minitest
SUBDIR += rubygem-minitest4
SUBDIR += rubygem-mixlib-authentication
diff --git a/devel/rubygem-micromachine/Makefile b/devel/rubygem-micromachine/Makefile
new file mode 100644
index 000000000000..adc6dcd55e99
--- /dev/null
+++ b/devel/rubygem-micromachine/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTNAME= micromachine
+PORTVERSION= 2.0.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Minimal Finite State Machine
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-micromachine/distinfo b/devel/rubygem-micromachine/distinfo
new file mode 100644
index 000000000000..07c2e9688633
--- /dev/null
+++ b/devel/rubygem-micromachine/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478007628
+SHA256 (rubygem/micromachine-2.0.0.gem) = a8aa5747ac1e6817375b8370139e7e3982aef4f56108ea7545d9288a076a3908
+SIZE (rubygem/micromachine-2.0.0.gem) = 8192
diff --git a/devel/rubygem-micromachine/pkg-descr b/devel/rubygem-micromachine/pkg-descr
new file mode 100644
index 000000000000..b51033817f39
--- /dev/null
+++ b/devel/rubygem-micromachine/pkg-descr
@@ -0,0 +1,9 @@
+There are many finite state machine implementations for Ruby, and they all
+provide a nice DSL for declaring events, exceptions, callbacks, and all kinds
+of niceties in general.
+
+But if all you want is a finite state machine, look no further: this has less
+than 50 lines of code and provides everything a finite state machine must have,
+and nothing more.
+
+WWW: http://github.com/soveran/micromachine