aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-21 04:58:21 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-21 04:58:21 +0800
commit0a604a30d383c2351e8ec0a1d4099408def988c9 (patch)
tree94c4f74303e8465a55e4aa11e63087050dfbfd35 /devel
parent96822d0e12b7915bdb8e7b84a01a59cf4f03bfcb (diff)
downloadfreebsd-ports-gnome-0a604a30d383c2351e8ec0a1d4099408def988c9.tar.gz
freebsd-ports-gnome-0a604a30d383c2351e8ec0a1d4099408def988c9.tar.zst
freebsd-ports-gnome-0a604a30d383c2351e8ec0a1d4099408def988c9.zip
devel/kore: unbreak build on 12.0
src/cli.c:385:9: error: generic selections are a C11-specific feature [-Werror,-Wc11-extensions] appl = basename(pwd); ^ /usr/include/libgen.h:60:21: note: expanded from macro 'basename' #define basename(x) __generic(x, const char *, __old_basename, basename)(x) ^ /usr/include/sys/cdefs.h:337:2: note: expanded from macro '__generic' _Generic(expr, t: yes, default: no) ^ PR: 214638 Reported by: pkg-fallout Submitted by: Tobias Kortkamp <t@tobik.me> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/kore/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/devel/kore/Makefile b/devel/kore/Makefile
index 34fbfe80e0a1..27488fff5eff 100644
--- a/devel/kore/Makefile
+++ b/devel/kore/Makefile
@@ -47,17 +47,16 @@ JSONRPC_LIB_DEPENDS= libyajl.so:devel/yajl
DEBUG_VARS= MAKE_ARGS+=DEBUG=1
-.include <bsd.port.pre.mk>
-
-.if ${SSL_DEFAULT} == base
-BROKEN_FreeBSD_9= Base OpenSSL on FreeBSD 9.x is too old
-.endif
+BROKEN_FreeBSD_9= does not build
post-patch:
-# Disable kore's own optimizations flags
- @${REINPLACE_CMD} 's|CFLAGS+=-O|#|g' ${WRKSRC}/Makefile
-# Make sure the correct flags are set when LOCALBASE is not /usr/local
- @${REINPLACE_CMD} 's|/usr/local/|${LOCALBASE}/|g' ${WRKSRC}/Makefile
+# Disable kore's own optimizations flags, make sure the correct flags
+# are set when LOCALBASE is not /usr/local, and allow __generic on
+# FreeBSD 12.0-CURRENT after r308264
+ @${REINPLACE_CMD} -e 's|CFLAGS+=-O|#|g' \
+ -e 's|/usr/local/|${LOCALBASE}/|g' \
+ -e 's|-pedantic|-pedantic -Wno-error=c11-extensions|g' \
+ ${WRKSRC}/Makefile
pre-install:
${STRIP_CMD} ${WRKSRC}/kore
@@ -66,4 +65,4 @@ post-install:
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/conf && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>