aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
committeraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
commit0a9e5efb9de6b8811964b263c03b83ec89719f71 (patch)
treeaf6266e338105f6caa968f90afd0c4e98288d6f5 /devel
parent161ee4e405ddee7d6c945754c827684829ef8e90 (diff)
downloadfreebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.gz
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.zst
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'devel')
-rw-r--r--devel/cvslines/Makefile11
-rw-r--r--devel/cvslines/pkg-descr2
-rw-r--r--devel/cvsplot/Makefile12
-rw-r--r--devel/cvsstat/Makefile8
-rw-r--r--devel/cvsweb/Makefile18
-rw-r--r--devel/cvsweb/pkg-descr2
-rw-r--r--devel/cvsweb3/Makefile18
-rw-r--r--devel/cvsweb3/pkg-descr2
-rw-r--r--devel/hypersrc/Makefile13
-rw-r--r--devel/p4db/Makefile11
-rw-r--r--devel/p5-Class-C3-Componentised/Makefile8
-rw-r--r--devel/p5-Class-Contract/Makefile11
-rw-r--r--devel/p5-Class-Default/Makefile9
-rw-r--r--devel/p5-Config-JFDI/Makefile3
-rw-r--r--devel/p5-Devel-Diagram/Makefile10
-rw-r--r--devel/p5-Devel-Timer/Makefile9
-rw-r--r--devel/p5-Inline-Tcl/Makefile8
-rw-r--r--devel/p5-MooseX-AttributeHelpers/Makefile8
-rw-r--r--devel/p5-MooseX-SimpleConfig/Makefile9
-rw-r--r--devel/p5-Return-Value/Makefile2
20 files changed, 51 insertions, 123 deletions
diff --git a/devel/cvslines/Makefile b/devel/cvslines/Makefile
index b3c54a1b8941..62efd26f7461 100644
--- a/devel/cvslines/Makefile
+++ b/devel/cvslines/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvslines
-# Date created: 24 Aug 1998
-# Whom: jkoshy
-#
+# Created by: jkoshy
# $FreeBSD$
-#
PORTNAME= cvslines
PORTVERSION= 1.6.9
@@ -16,6 +12,8 @@ COMMENT= Wrapper to ease merging of changes between CVS branches
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_PERL5= yes
NO_BUILD= yes
+USES= shebangfix
+SHEBANG_FILES= cvslines
.for ii in s s_check s-check s-commit s-config s-status
PLIST_FILES+= bin/cvsline${ii}
.endfor
@@ -23,8 +21,7 @@ PLIST_FILES+= bin/cvsline${ii}
MAN1= cvslines.1
pre-patch:
- ${PERL} -pi -e "s:usr/bin/perl5:${PERL5}:g" ${WRKSRC}/cvslines
- ${PERL} -pi -e "s:the the:the:g" ${WRKSRC}/cvslines.1
+ @${REINPLACE_CMD} -i '' -e 's|the the|the|' ${WRKSRC}/cvslines.1
do-install:
PREFIX=${PREFIX} ${PERL5} ${WRKSRC}/INSTALL ${WRKSRC}/CONFIG
diff --git a/devel/cvslines/pkg-descr b/devel/cvslines/pkg-descr
index 1a202f23bfe7..177ea2cba698 100644
--- a/devel/cvslines/pkg-descr
+++ b/devel/cvslines/pkg-descr
@@ -5,4 +5,4 @@ cvslines is a "wrapper" facility that helps out with merging changes
between various cvs branches, where the branches represent different
lines of development.
-WWW: http://cvslines.sourceforge.net/menu.html
+WWW: http://cvslines.sourceforge.net/menu.html
diff --git a/devel/cvsplot/Makefile b/devel/cvsplot/Makefile
index d058cc181437..1f1485f606c8 100644
--- a/devel/cvsplot/Makefile
+++ b/devel/cvsplot/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: cvsplot
-# Date created: May 31, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= cvsplot
PORTVERSION= 1.7.4
@@ -22,9 +17,8 @@ RUN_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
USE_PERL5= yes
NO_BUILD= yes
PLIST_FILES= bin/cvsplot
-
-post-patch:
- @${PERL} -pi -e "s,^#!/usr/bin/perl -w,#!/usr/bin/env perl -w,g" ${WRKSRC}/cvsplot.pl
+USES= shebangfix
+SHEBANG_FILES= cvsplot.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cvsplot.pl ${PREFIX}/bin/cvsplot
diff --git a/devel/cvsstat/Makefile b/devel/cvsstat/Makefile
index 145dee687cae..657d1ba0e692 100644
--- a/devel/cvsstat/Makefile
+++ b/devel/cvsstat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsstat
-# Date created: 27 August 2001
-# Whom: petef
-#
+# Created by: petef
# $FreeBSD$
-#
PORTNAME= cvsstat
PORTVERSION= 2.24
@@ -26,7 +22,7 @@ do-extract:
@${CP} -p ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}
post-patch:
- @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/cvsstat
+ @${REINPLACE_CMD} -i '' -e 's|perl -S|${PERL} -S|' ${WRKSRC}/cvsstat
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cvsstat ${PREFIX}/bin
diff --git a/devel/cvsweb/Makefile b/devel/cvsweb/Makefile
index 0fd25a760e19..7d567623576d 100644
--- a/devel/cvsweb/Makefile
+++ b/devel/cvsweb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsweb
-# Date created: 27 Jun 1999
-# Whom: SADA Kenji <sada@FreeBSD.org>
-#
+# Created by: SADA Kenji <sada@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cvsweb
PORTVERSION= 2.0.6
@@ -55,14 +51,12 @@ SUB_FILES= pkg-message
SUB_LIST= PREFIX="${PREFIX}" DOCSDIR="${DOCSDIR}"
post-patch:
- ${PERL} -i -pe "\
- s'!!PERL!!'${PERL}'g; \
- s'!!PREFIX!!'${PREFIX}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PERL!!,${PERL},' \
+ -e 's,!!PREFIX!!,${PREFIX},' \
${WRKSRC}/cvsweb.cgi
- ${PERL} -i -pe "\
- s'!!PREFIX!!'${PREFIX}'g; \
- s'!!CVSROOT!!'${CVSROOT}'g; \
- s'!!TITLE!!'${TITLE}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PREFIX!!,${PREFIX},' \
+ -e 's,!!CVSROOT!!,${CVSROOT},' \
+ -e 's,!!TITLE!!,${TITLE},' \
${WRKSRC}/cvsweb.conf
do-install:
diff --git a/devel/cvsweb/pkg-descr b/devel/cvsweb/pkg-descr
index e529dbba570c..22ac5a46e92b 100644
--- a/devel/cvsweb/pkg-descr
+++ b/devel/cvsweb/pkg-descr
@@ -11,4 +11,4 @@ brought it back to the FreeBSD community and made further
improvements.
Author: The FreeBSD Project <freebsd-cvsweb at FreeBSD dot org>
-WWW: http://www.FreeBSD.org/projects/cvsweb.html
+WWW: http://www.FreeBSD.org/projects/cvsweb.html
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index 41f1bd03770b..69e64068294b 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsweb
-# Date created: 27 Jun 1999
-# Whom: SADA Kenji <sada@FreeBSD.org>
-#
+# Created by: SADA Kenji <sada@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cvsweb
PORTVERSION= 3.0.6
@@ -79,14 +75,12 @@ SUB_FILES= pkg-message
SUB_LIST= PREFIX="${PREFIX}" DOCSDIR="${DOCSDIR}"
post-patch:
- ${PERL} -i -pe "\
- s'!!PERL!!'${PERL}'g; \
- s'!!PREFIX!!'${PREFIX}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PERL!!,${PERL},' \
+ -e 's,!!PREFIX!!,${PREFIX},' \
${WRKSRC}/cvsweb.cgi
- ${PERL} -i -pe "\
- s'!!PREFIX!!'${PREFIX}'g; \
- s'!!CVSROOT!!'${CVSROOT}'g; \
- s'!!TITLE!!'${TITLE}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PREFIX!!,${PREFIX},' \
+ -e 's,!!CVSROOT!!,${CVSROOT},' \
+ -e 's,!!TITLE!!,${TITLE},' \
${WRKSRC}/cvsweb.conf
do-install:
diff --git a/devel/cvsweb3/pkg-descr b/devel/cvsweb3/pkg-descr
index 8eb3cce32ffc..37e0c506eead 100644
--- a/devel/cvsweb3/pkg-descr
+++ b/devel/cvsweb3/pkg-descr
@@ -11,4 +11,4 @@ brought it back to the FreeBSD community and made further
improvements. FreeBSD-CVSweb is currently maintained by Ville Skytta.
Author: The FreeBSD Project <freebsd-cvsweb at FreeBSD dot org>
-WWW: http://www.FreeBSD.org/projects/cvsweb.html
+WWW: http://www.FreeBSD.org/projects/cvsweb.html
diff --git a/devel/hypersrc/Makefile b/devel/hypersrc/Makefile
index 1dc15c799b2b..6719acc21f14 100644
--- a/devel/hypersrc/Makefile
+++ b/devel/hypersrc/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: hypersrc
-# Date created: Apr 9, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= hypersrc
PORTVERSION= 5.4.21
@@ -26,13 +21,15 @@ USE_GNOME= gnomelibs
USE_GMAKE= yes
MAKEFILE= GNUmakefile
MAKE_ARGS= CC="${CC}" C_OPTIMIZE="${CFLAGS}"
+USES= shebangfix
+SHEBANG_FILES= Hypersrc.pl
MAN1= hypersrc.1
PLIST_FILES= bin/hypersrc bin/Hypersrc.pl bin/ctags.pl
post-patch:
- @${PERL} -pi -e 's|"ctags"|"${LOCALBASE}/bin/exctags"|g ; \
- s|"ctags.pl"|"${PREFIX}/bin/ctags.pl"|g' ${WRKSRC}/Hypersrc.pl
+ @${REINPLACE_CMD} -i '' -e 's|"ctags"|"${LOCALBASE}/bin/exctags"|' \
+ -e 's|"ctags.pl"|"${PREFIX}/bin/ctags.pl"|' ${WRKSRC}/Hypersrc.pl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/out/hypersrc ${PREFIX}/bin
diff --git a/devel/p4db/Makefile b/devel/p4db/Makefile
index c9c3bf620e82..0625606b7025 100644
--- a/devel/p4db/Makefile
+++ b/devel/p4db/Makefile
@@ -45,12 +45,11 @@ post-extract:
done
post-patch:
- ${PERL} -pi \
- -e 's,!!PREFIX!!,${PREFIX},g;' \
- -e 's,!!PERFORCE_USER!!,p4admin,g;' \
- -e 's,!!PERFORCE_GROUP!!,p4admin,g;' \
- -e 's,!!PERFORCE_PORT!!,${PERFORCE_PORT},g;' \
- -e 's,!!FQDN!!,${FQDN},g;' \
+ @${REINPLACE_CMD} -i '' -e 's,!!PREFIX!!,${PREFIX},' \
+ -e 's,!!PERFORCE_USER!!,p4admin,' \
+ -e 's,!!PERFORCE_GROUP!!,p4admin,' \
+ -e 's,!!PERFORCE_PORT!!,${PERFORCE_PORT},' \
+ -e 's,!!FQDN!!,${FQDN},' \
${WRKSRC}/${PORTNAME}/P4DB.conf.sample
${FIND} ${WRKSRC}/${PORTNAME} -name '*.orig' -delete
diff --git a/devel/p5-Class-C3-Componentised/Makefile b/devel/p5-Class-C3-Componentised/Makefile
index d24daa3fa51a..8bec9e7a4fb9 100644
--- a/devel/p5-Class-C3-Componentised/Makefile
+++ b/devel/p5-Class-C3-Componentised/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-C3-Componentised
-# Date created: 2007-08-13
-# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
-#
+# Created by: Lars Balker Rasmussen <lbr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Class-C3-Componentised
PORTVERSION= 1.0009
@@ -31,6 +27,6 @@ PERL_CONFIGURE= yes
MAN3= Class::C3::Componentised.3
post-extract:
- @${PERL} -i.bak -ne 'print unless m,Test::,' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e '/Test::/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-Class-Contract/Makefile b/devel/p5-Class-Contract/Makefile
index 0e1d682bf757..2c435cdf69c4 100644
--- a/devel/p5-Class-Contract/Makefile
+++ b/devel/p5-Class-Contract/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class::Contract
-# Date created: 5 Nov 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Class-Contract
PORTVERSION= 1.14
@@ -15,14 +11,11 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Design-by-Contract OO in Perl
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
PLIST_SUB+= EXAMPLESDIR="share/examples/${PORTNAME}"
MAN3= Class::Contract.3 Class::Contract::Production.3
-post-patch:
- @${FIND} ${WRKSRC} -type f -name "*.p[lm]" | \
- ${XARGS} ${PERL} -pi -e 's/\x0d//g;'
-
pre-configure:
${MKDIR} ${WRKSRC}/examples
${MV} ${WRKSRC}/demo.pl ${WRKSRC}/examples
diff --git a/devel/p5-Class-Default/Makefile b/devel/p5-Class-Default/Makefile
index 239a021e72c7..710ae7e26f5f 100644
--- a/devel/p5-Class-Default/Makefile
+++ b/devel/p5-Class-Default/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-Default
-# Date created: 10 December 2002
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Class-Default
PORTVERSION= 1.51
@@ -21,7 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Class::Default.3
-post-patch:
- @${PERL} -pi -e 's/^auto_install.*$$//' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/devel/p5-Config-JFDI/Makefile b/devel/p5-Config-JFDI/Makefile
index 44b4491d1b62..372bb3da71a4 100644
--- a/devel/p5-Config-JFDI/Makefile
+++ b/devel/p5-Config-JFDI/Makefile
@@ -30,7 +30,6 @@ PERL_CONFIGURE= yes
MAN3= Config::JFDI.3
post-extract:
- @${PERL} -i -ne 'print unless /\.swp$$/' ${WRKSRC}/MANIFEST
- @${PERL} -i.bak -ne 'print unless m,^Test::,' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/Test::/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-Devel-Diagram/Makefile b/devel/p5-Devel-Diagram/Makefile
index fcc1022f69f3..54c9e55e4043 100644
--- a/devel/p5-Devel-Diagram/Makefile
+++ b/devel/p5-Devel-Diagram/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Devel-Diagram
-# Date created: 25 January 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Devel-Diagram
PORTVERSION= 1.00
@@ -15,12 +11,10 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Discover the classes of an arbitrary suite of Perl modules
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
MAN3= Devel::Diagram.3 Devel::Diagram::Render::UXF20.3
-post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
-
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
diff --git a/devel/p5-Devel-Timer/Makefile b/devel/p5-Devel-Timer/Makefile
index 81b54720a92e..c56857f17a2f 100644
--- a/devel/p5-Devel-Timer/Makefile
+++ b/devel/p5-Devel-Timer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Devel-Timer
-# Date created: 2006-12-11
-# Whom: Cory R. King <coryking@mozimediacom>
-#
+# Created by: Cory R. King <coryking@mozimediacom>
# $FreeBSD$
-#
PORTNAME= Devel-Timer
PORTVERSION= 0.04
@@ -19,7 +15,4 @@ PERL_CONFIGURE= yes
MAN3= Devel::Timer.3
-post-extract:
- @${PERL} -pi -e '$$_ = undef if /''OPTIMIZE''/' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/devel/p5-Inline-Tcl/Makefile b/devel/p5-Inline-Tcl/Makefile
index e061767b05ac..73762935b78f 100644
--- a/devel/p5-Inline-Tcl/Makefile
+++ b/devel/p5-Inline-Tcl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Inline::Tcl
-# Date created: 14 Dec 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Inline-Tcl
PORTVERSION= 0.09
@@ -25,6 +21,6 @@ CONFIGURE_ARGS= INC="-I${PREFIX}/include/tcl8.4" \
MAN3= Inline::Tcl.3
post-patch:
- @${PERL} -pi -e '$$_="" if $$.>1 && $$.<100' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i.bak '2,99d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-AttributeHelpers/Makefile b/devel/p5-MooseX-AttributeHelpers/Makefile
index cf2d464597f7..8e541599e692 100644
--- a/devel/p5-MooseX-AttributeHelpers/Makefile
+++ b/devel/p5-MooseX-AttributeHelpers/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-MooseX-AttributeHelpers
-# Date created: 27 Jul 2008
-# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
-#
+# Created by: Lars Balker Rasmussen <lbr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= MooseX-AttributeHelpers
PORTVERSION= 0.23
@@ -53,6 +49,6 @@ MAN3= MooseX::AttributeHelpers.3 \
MooseX::AttributeHelpers::Trait::String.3
post-extract:
- @${PERL} -i -ne 'print unless m,build_requires,' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/build_requires/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-SimpleConfig/Makefile b/devel/p5-MooseX-SimpleConfig/Makefile
index 371096858b1c..3c0a30c038ff 100644
--- a/devel/p5-MooseX-SimpleConfig/Makefile
+++ b/devel/p5-MooseX-SimpleConfig/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/MooseX-SimpleConfig
-# Date created: 25 February 2009
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= MooseX-SimpleConfig
PORTVERSION= 0.09
@@ -24,6 +20,7 @@ PERL_CONFIGURE= yes
MAN3= MooseX::SimpleConfig.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/Test::More|auto_install/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e '/auto_install/d' -e '/Test::More/d' \
+ ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-Return-Value/Makefile b/devel/p5-Return-Value/Makefile
index fd5d618efc45..8d6d82afaf63 100644
--- a/devel/p5-Return-Value/Makefile
+++ b/devel/p5-Return-Value/Makefile
@@ -17,6 +17,6 @@ PERL_CONFIGURE= yes
MAN3= Return::Value.3
post-patch:
- ${PERL} -pi -e 's/^Carp::cluck/# Carp::cluck/' ${WRKSRC}/lib/Return/Value.pm
+ @${REINPLACE_CMD} -i '' -e 's/^Carp::cluck/# Carp::cluck/' ${WRKSRC}/lib/Return/Value.pm
.include <bsd.port.mk>