aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-02-21 05:31:07 +0800
committertota <tota@FreeBSD.org>2012-02-21 05:31:07 +0800
commit0ae445dd6177b283f31a569dbc8a8349e2b9b31b (patch)
treeecb88abdbd86419dceb90a623655288cf6dae049 /devel
parentd19af5c87d9827d21dadf2d08b294594d0a1f4c8 (diff)
downloadfreebsd-ports-gnome-0ae445dd6177b283f31a569dbc8a8349e2b9b31b.tar.gz
freebsd-ports-gnome-0ae445dd6177b283f31a569dbc8a8349e2b9b31b.tar.zst
freebsd-ports-gnome-0ae445dd6177b283f31a569dbc8a8349e2b9b31b.zip
- Drag from Attic
- Update to 2.3.33 - Add LICENSE_FILE - Update WWW line in pkg-descr - Fix pkg-plist - Take maintainership PR: ports/164786 Submitted by: tota (myself) Approved by: gahr (previous maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/simian/Makefile102
-rw-r--r--devel/simian/distinfo2
-rw-r--r--devel/simian/files/simian.in12
-rw-r--r--devel/simian/pkg-descr11
-rw-r--r--devel/simian/pkg-plist10
6 files changed, 138 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b5c6a8468f43..00abd7886b0e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3838,6 +3838,7 @@
SUBDIR += silc-toolkit
SUBDIR += silentbob
SUBDIR += simgear
+ SUBDIR += simian
SUBDIR += simpletest
SUBDIR += simulavr
SUBDIR += skalibs
diff --git a/devel/simian/Makefile b/devel/simian/Makefile
new file mode 100644
index 000000000000..1ad59e995c85
--- /dev/null
+++ b/devel/simian/Makefile
@@ -0,0 +1,102 @@
+# New ports collection makefile for: simian
+# Date created: July 8, 2005
+# Whom: andreas@syndrom23.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= simian
+PORTVERSION= 2.3.33
+CATEGORIES= devel java
+MASTER_SITES= http://www.harukizaemon.com/simian/
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Similarity analyser for source and other text files
+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+.if defined(WITHOUT_JAVA) && !defined(WITH_MONO)
+WITH_MONO= yes
+.endif
+
+.if defined(WITH_MONO)
+RUN_DEPENDS+= mono:${PORTSDIR}/lang/mono
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+.if !defined(WITHOUT_JAVA)
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+PLIST_SUB+= JAVA=""
+SUB_LIST+= JAVA=""
+.else
+PLIST_SUB+= JAVA="@comment "
+SUB_LIST+= JAVA="@comment "
+.endif
+
+.if defined(WITH_MONO)
+PLIST_SUB+= MONO=""
+SUB_LIST+= MONO=""
+.else
+PLIST_SUB+= MONO="@comment "
+SUB_LIST+= MONO="@comment "
+.endif
+
+.if defined(PACKAGE_BUILDING)
+RESTRICTED= Have to agree to license before download
+.endif
+
+SUB_FILES= simian
+SUB_LIST+= VERSION=${PORTVERSION}
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= changes.html customers.html features.html \
+ get_dotnet.png get_it_now.html \
+ get_java_blue-button.gif index.html installation.html \
+ simian.jpg \
+ javadoc
+.endif
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !defined(PACKAGE_BUILDING) && (!defined(SIMIAN_AGREE_LICENSE) || ${SIMIAN_AGREE_LICENSE} != "yes")
+ @${ECHO} By downloading this version, you agree to the terms
+ @${ECHO} and conditions set out in the license agreement and
+ @${ECHO} you agree that, should you wish to continue using
+ @${ECHO} Simian for other than open source projects, non-
+ @${ECHO} commercial projects or evaluation purposes for a
+ @${ECHO} period greater than 15 days, you will purchase a
+ @${ECHO} license as described following URL.
+ @${ECHO}
+ @${ECHO} http://www.harukizaemon.com/simian/LICENSE.txt
+ @${ECHO}
+ @${ECHO} Build with SIMIAN_AGREE_LICENSE=yes to continue.
+ @${ECHO}
+ @${FALSE}
+.endif
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/xsl/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/simian.xsl ${PREFIX}/share/xsl/${PORTNAME}
+ @${MKDIR} ${PREFIX}/simian/bin
+.if !defined(WITHOUT_JAVA)
+ ${INSTALL_DATA} ${WRKSRC}/bin/simian-${PORTVERSION}.jar ${PREFIX}/simian/bin
+.endif
+.if defined(WITH_MONO)
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/*.dll ${PREFIX}/simian/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/simian-${PORTVERSION}.exe ${PREFIX}/simian/bin
+.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/simian ${PREFIX}/bin/simian
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} \
+ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/\{} \; \
+ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} \{} ${DOCSDIR}/\{} \;
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/simian/distinfo b/devel/simian/distinfo
new file mode 100644
index 000000000000..26cd9172a66a
--- /dev/null
+++ b/devel/simian/distinfo
@@ -0,0 +1,2 @@
+SHA256 (simian-2.3.33.tar.gz) = 489c90dca3283d8c30778b9cdda0b992a23bb65d1ffdef7ef6c27ea2f3dbe529
+SIZE (simian-2.3.33.tar.gz) = 3271470
diff --git a/devel/simian/files/simian.in b/devel/simian/files/simian.in
new file mode 100644
index 000000000000..ee470eb1a343
--- /dev/null
+++ b/devel/simian/files/simian.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+%%JAVA%%MONO=
+
+%%MONO%%MONO=%%LOCALBASE%%/bin/mono
+%%MONO%%
+%%MONO%%$MONO %%PREFIX%%/simian/bin/simian-%%VERSION%%.exe $@
+
+%%JAVA%%if [ "x$MONO" = "x" ]; then
+%%JAVA%% JAVA=`which java`
+%%JAVA%% $JAVA -jar %%PREFIX%%/simian/bin/simian-%%VERSION%%.jar $@
+%%JAVA%%fi
diff --git a/devel/simian/pkg-descr b/devel/simian/pkg-descr
new file mode 100644
index 000000000000..6086e66fb6c5
--- /dev/null
+++ b/devel/simian/pkg-descr
@@ -0,0 +1,11 @@
+Simian (Similarity Analyser) identifies duplication in Java, C#,
+C, C++, COBOL, Ruby, JSP, ASP, HTML, XML, Visual Basic Groovy source
+code and even plain text files. In fact, simian can be used on any
+human readable files such as ini files, deployment descriptors, you
+name it.
+
+Note: The port uses the java version by default. You can select the .NET
+ version via WITH_MONO=yes, and disable installation of the
+ java parts with WITHOUT_JAVA=yes.
+
+WWW: http://www.harukizaemon.com/simian/
diff --git a/devel/simian/pkg-plist b/devel/simian/pkg-plist
new file mode 100644
index 000000000000..2f42e58d8b88
--- /dev/null
+++ b/devel/simian/pkg-plist
@@ -0,0 +1,10 @@
+bin/simian
+%%JAVA%%simian/bin/simian-%%VERSION%%.jar
+%%MONO%%simian/bin/simian-%%VERSION%%.exe
+%%MONO%%simian/bin/IKVM.GNU.Classpath.dll
+%%MONO%%simian/bin/IKVM.Runtime.dll
+share/xsl/simian/simian.xsl
+@dirrm simian/bin
+@dirrm simian
+@dirrm share/xsl/simian
+@dirrmtry share/xsl