aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-14 19:09:40 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-14 19:09:40 +0800
commit0b52312f0c25b96e26ccd1a363ceebeefd169d3a (patch)
tree40efe4f77b59995c99aed948b6d2b09f6cd12aeb /devel
parent7ea2881f65d185dcbadf11b63f79bef45aed8ea5 (diff)
downloadfreebsd-ports-gnome-0b52312f0c25b96e26ccd1a363ceebeefd169d3a.tar.gz
freebsd-ports-gnome-0b52312f0c25b96e26ccd1a363ceebeefd169d3a.tar.zst
freebsd-ports-gnome-0b52312f0c25b96e26ccd1a363ceebeefd169d3a.zip
Fix build by using a single clisp session.
Diffstat (limited to 'devel')
-rw-r--r--devel/cl-asdf-clisp/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/cl-asdf-clisp/Makefile b/devel/cl-asdf-clisp/Makefile
index 4a4626d6c843..c25f5f2037d8 100644
--- a/devel/cl-asdf-clisp/Makefile
+++ b/devel/cl-asdf-clisp/Makefile
@@ -27,11 +27,10 @@ post-extract:
@${MKDIR} ${WRKSRC}
do-build:
- @for FILE in ${ASDF_MODULES}; do \
- clisp -q -ansi -norc \
- -x "(compile-file \"${LOCALBASE}/lib/common-lisp/asdf/$${FILE}\" :output-file \"${WRKSRC}/$$(${BASENAME} $${FILE} .lisp).fasl\")" \
- -x "(quit)"; \
- done
+ @clisp -q -ansi -norc \
+ -x "(compile-file \"${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp\" :output-file \"${WRKSRC}/asdf.fasl\")" \
+ -x "(compile-file \"${LOCALBASE}/lib/common-lisp/asdf/wild-modules.lisp\" :output-file \"${WRKSRC}/wild-modules.fasl\")" \
+ -x "(quit)";
do-install:
@${MKDIR} ${PREFIX}/lib/common-lisp/asdf/clispfasl