aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-06-27 03:10:10 +0800
committermarino <marino@FreeBSD.org>2015-06-27 03:10:10 +0800
commit0c6efb3d190b1938d615aa4a0b8195712582486f (patch)
tree4734b28e6ef1fa873066e59d2baa20c68b364cee /devel
parenta727226a289c5d8be2d47c649ddc4c6fb43c7684 (diff)
downloadfreebsd-ports-gnome-0c6efb3d190b1938d615aa4a0b8195712582486f.tar.gz
freebsd-ports-gnome-0c6efb3d190b1938d615aa4a0b8195712582486f.tar.zst
freebsd-ports-gnome-0c6efb3d190b1938d615aa4a0b8195712582486f.zip
devel/deforaos-libsystem is not jobs safe
Here the log shows a makefile race where it tries to create the same symlink twice: --- libSystem.so.0 --- ln -f -s -- libSystem.so.0.0 libSystem.so.0 --- libSystem.so --- ln -f -s -- libSystem.so.0.0 libSystem.so.0 --- libSystem.so.0 --- ln -f -s -- libSystem.so.0.0 libSystem.so --- libSystem.so --- ln: libSystem.so.0: File exists
Diffstat (limited to 'devel')
-rw-r--r--devel/deforaos-libsystem/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/deforaos-libsystem/Makefile b/devel/deforaos-libsystem/Makefile
index a452d104679d..367ff4e543c2 100644
--- a/devel/deforaos-libsystem/Makefile
+++ b/devel/deforaos-libsystem/Makefile
@@ -20,6 +20,8 @@ CPPFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
MAKE_ARGS+= PREFIX=${PREFIX}
+MAKE_JOBS_UNSAFE= yes
+
OPTIONS_DEFAULT= DOCS
post-patch: