aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2009-01-28 00:26:17 +0800
committerglarkin <glarkin@FreeBSD.org>2009-01-28 00:26:17 +0800
commit0e1a1ba2a00860e2adf27d46fb0847091d65d502 (patch)
treeefcb92d9c314cb87f211a76637ac0d931f57cc96 /devel
parent137918455bc72eb6abed172e12a17b2647a4de24 (diff)
downloadfreebsd-ports-gnome-0e1a1ba2a00860e2adf27d46fb0847091d65d502.tar.gz
freebsd-ports-gnome-0e1a1ba2a00860e2adf27d46fb0847091d65d502.tar.zst
freebsd-ports-gnome-0e1a1ba2a00860e2adf27d46fb0847091d65d502.zip
SVN-Hooks is a Perl framework for creating Subversion hooks.
It comes with a bunch of plugins (actually, sub-modules of SVN::Hooks) that implement some of the most used standalone Subversion hooks available, such as pre-commit hooks for enforcing: - the log message format - property settings - the repository structure - restrictions on the modification of repository areas (e.g., /tags) - restrictions on filenames - the integration with ticketing systems It also comes with post-commit hooks for: - sending commit emails - updating configuration files in the server from changes made in the repository But as a framework, it can be extended to implement all types of hooks. WWW: http://search.cpan.org/dist/SVN-Hooks/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-Hooks/Makefile40
-rw-r--r--devel/p5-SVN-Hooks/distinfo3
-rw-r--r--devel/p5-SVN-Hooks/pkg-descr23
-rw-r--r--devel/p5-SVN-Hooks/pkg-plist17
5 files changed, 84 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e0fb37aff48d..a243e0bea4ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1689,6 +1689,7 @@
SUBDIR += p5-SVN-Agent
SUBDIR += p5-SVN-Dump
SUBDIR += p5-SVN-Hook
+ SUBDIR += p5-SVN-Hooks
SUBDIR += p5-SVN-Log
SUBDIR += p5-SVN-Look
SUBDIR += p5-SVN-Mirror
diff --git a/devel/p5-SVN-Hooks/Makefile b/devel/p5-SVN-Hooks/Makefile
new file mode 100644
index 000000000000..1e1a236c334e
--- /dev/null
+++ b/devel/p5-SVN-Hooks/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: SVN::Hooks
+# Date created: 2009-01-27
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Hooks
+PORTVERSION= 0.13.12
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A framework for implementing Subversion hooks
+
+RUN_DEPENDS= p5-Email-Send>=0:${PORTSDIR}/mail/p5-Email-Send \
+ p5-Email-Simple>=0:${PORTSDIR}/mail/p5-Email-Simple \
+ p5-Email-Simple-Creator>=0:${PORTSDIR}/mail/p5-Email-Simple-Creator \
+ p5-SVN-Look>=0:${PORTSDIR}/devel/p5-SVN-Look \
+ p5-SVN-Notify>=0:${PORTSDIR}/devel/p5-SVN-Notify \
+ ${SITE_PERL}/XMLRPC/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Hooks.3 \
+ SVN::Hooks::AllowLogChange.3 \
+ SVN::Hooks::CheckLog.3 \
+ SVN::Hooks::CheckMimeTypes.3 \
+ SVN::Hooks::CheckProperty.3 \
+ SVN::Hooks::CheckStructure.3 \
+ SVN::Hooks::DenyChanges.3 \
+ SVN::Hooks::DenyFilenames.3 \
+ SVN::Hooks::JiraAcceptance.3 \
+ SVN::Hooks::Mailer.3 \
+ SVN::Hooks::Notify.3 \
+ SVN::Hooks::UpdateConfFile.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Hooks/distinfo b/devel/p5-SVN-Hooks/distinfo
new file mode 100644
index 000000000000..9cfc9966e7b4
--- /dev/null
+++ b/devel/p5-SVN-Hooks/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-Hooks-0.13.12.tar.gz) = 98b5fba8e269edad095b8ec5be25bd1b
+SHA256 (SVN-Hooks-0.13.12.tar.gz) = 8c9fe09718db946b1de143fee823e125cb4666784a8889ee4b021e5336804161
+SIZE (SVN-Hooks-0.13.12.tar.gz) = 25387
diff --git a/devel/p5-SVN-Hooks/pkg-descr b/devel/p5-SVN-Hooks/pkg-descr
new file mode 100644
index 000000000000..f8545876efee
--- /dev/null
+++ b/devel/p5-SVN-Hooks/pkg-descr
@@ -0,0 +1,23 @@
+SVN-Hooks is a Perl framework for creating Subversion hooks.
+
+It comes with a bunch of plugins (actually, sub-modules of SVN::Hooks)
+that implement some of the most used standalone Subversion hooks
+available, such as pre-commit hooks for enforcing:
+
+- the log message format
+- property settings
+- the repository structure
+- restrictions on the modification of repository areas (e.g., /tags)
+- restrictions on filenames
+- the integration with ticketing systems
+
+It also comes with post-commit hooks for:
+
+- sending commit emails
+- updating configuration files in the server from changes made in
+ the repository
+
+But as a framework, it can be extended to implement all types of
+hooks.
+
+WWW: http://search.cpan.org/dist/SVN-Hooks/
diff --git a/devel/p5-SVN-Hooks/pkg-plist b/devel/p5-SVN-Hooks/pkg-plist
new file mode 100644
index 000000000000..9f52eb0e778d
--- /dev/null
+++ b/devel/p5-SVN-Hooks/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/SVN/Hooks.pm
+%%SITE_PERL%%/SVN/Hooks/AllowLogChange.pm
+%%SITE_PERL%%/SVN/Hooks/CheckLog.pm
+%%SITE_PERL%%/SVN/Hooks/CheckMimeTypes.pm
+%%SITE_PERL%%/SVN/Hooks/CheckProperty.pm
+%%SITE_PERL%%/SVN/Hooks/CheckStructure.pm
+%%SITE_PERL%%/SVN/Hooks/DenyChanges.pm
+%%SITE_PERL%%/SVN/Hooks/DenyFilenames.pm
+%%SITE_PERL%%/SVN/Hooks/JiraAcceptance.pm
+%%SITE_PERL%%/SVN/Hooks/Mailer.pm
+%%SITE_PERL%%/SVN/Hooks/Notify.pm
+%%SITE_PERL%%/SVN/Hooks/UpdateConfFile.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Hooks/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Hooks
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN
+@dirrm %%SITE_PERL%%/SVN/Hooks
+@dirrmtry %%SITE_PERL%%/SVN