aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-01-26 18:20:14 +0800
committerkoobs <koobs@FreeBSD.org>2016-01-26 18:20:14 +0800
commit11b46decc3775de1ad11af875081fea4cff4be3d (patch)
tree0a2c91a484e9da33170e7b588c785bbc15ff5093 /devel
parent65e60ebbc6c62e2983faa6601e38eb4a6204acee (diff)
downloadfreebsd-ports-gnome-11b46decc3775de1ad11af875081fea4cff4be3d.tar.gz
freebsd-ports-gnome-11b46decc3775de1ad11af875081fea4cff4be3d.tar.zst
freebsd-ports-gnome-11b46decc3775de1ad11af875081fea4cff4be3d.zip
devel/py-trollius: Fix TEST_DEPENDS
- Make mock a conditional TEST_DEPENDS - Add missing unittest2 TEST_DEPENDS - Remove run-aiotest from test target. Requires aiotest (PyPI) Didn't pick this up in testing because mock and unittest2 were installed locally, and running test: in poudriere is non-trivial at the moment. PR: 206578
Diffstat (limited to 'devel')
-rw-r--r--devel/py-trollius/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/py-trollius/Makefile b/devel/py-trollius/Makefile
index a587be926076..a22d8dcaa8c6 100644
--- a/devel/py-trollius/Makefile
+++ b/devel/py-trollius/Makefile
@@ -12,8 +12,6 @@ COMMENT= Port of the Tulip project (asyncio module, PEP 3156) on Python 2
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
-
USES= python
USE_PYTHON= autoplist distutils
@@ -23,11 +21,14 @@ NO_ARCH= yes
.if ${PYTHON_REL} < 3000
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}futures>0:${PORTSDIR}/devel/py-futures
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
+.if ${PYTHON_REL} < 3300
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+.endif
.endif
do-test:
@cd ${WRKSRC} && \
- ${PYTHON_CMD} runtests.py && \
- ${PYTHON_CMD} run_aiotest.py
+ ${PYTHON_CMD} runtests.py
.include <bsd.port.post.mk>