aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-08 03:12:08 +0800
committerknu <knu@FreeBSD.org>2001-03-08 03:12:08 +0800
commit1311d96209ea04c633e41b077a0f2bf9dc76db36 (patch)
treef0c5668771ae66bbbcef16a1f72cc27489da6b04 /devel
parentf091d556c3ae0b6bd4079d367a235af7cf68771a (diff)
downloadfreebsd-ports-gnome-1311d96209ea04c633e41b077a0f2bf9dc76db36.tar.gz
freebsd-ports-gnome-1311d96209ea04c633e41b077a0f2bf9dc76db36.tar.zst
freebsd-ports-gnome-1311d96209ea04c633e41b077a0f2bf9dc76db36.zip
Add ruby-mmap, a Ruby interface to manage memory-mapped file objects.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-mmap/Makefile37
-rw-r--r--devel/ruby-mmap/distinfo1
-rw-r--r--devel/ruby-mmap/pkg-comment1
-rw-r--r--devel/ruby-mmap/pkg-descr4
-rw-r--r--devel/ruby-mmap/pkg-plist8
6 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 93cc1bfdc1e2..c672987aba80 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -363,6 +363,7 @@
SUBDIR += ruby-intl
SUBDIR += ruby-libglade
SUBDIR += ruby-locale
+ SUBDIR += ruby-mmap
SUBDIR += ruby-mutexm
SUBDIR += ruby-optparse
SUBDIR += ruby-property
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
new file mode 100644
index 000000000000..343ccabe7baf
--- /dev/null
+++ b/devel/ruby-mmap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby-Mmap
+# Date created: 8 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mmap
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= ftp://moulon.inra.fr/pub/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README.en mmap.html mmap.rd
+EXAMPLES= aa b.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-mmap/distinfo b/devel/ruby-mmap/distinfo
new file mode 100644
index 000000000000..b7709953d725
--- /dev/null
+++ b/devel/ruby-mmap/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/mmap-0.1.tar.gz) = 79b41ab5018168f45ece47372d2cdbc5
diff --git a/devel/ruby-mmap/pkg-comment b/devel/ruby-mmap/pkg-comment
new file mode 100644
index 000000000000..376e1a96a919
--- /dev/null
+++ b/devel/ruby-mmap/pkg-comment
@@ -0,0 +1 @@
+Ruby interface to manage memory-mapped file objects
diff --git a/devel/ruby-mmap/pkg-descr b/devel/ruby-mmap/pkg-descr
new file mode 100644
index 000000000000..272aaa65f3fb
--- /dev/null
+++ b/devel/ruby-mmap/pkg-descr
@@ -0,0 +1,4 @@
+Ruby-Mmap is an interface to manage memory-mapped file objects.
+
+Author: Guy Decoux <ts@moulon.inra.fr>
+WWW: http://moulon.inra.fr/ruby/mmap.html
diff --git a/devel/ruby-mmap/pkg-plist b/devel/ruby-mmap/pkg-plist
new file mode 100644
index 000000000000..ef57d01448b5
--- /dev/null
+++ b/devel/ruby-mmap/pkg-plist
@@ -0,0 +1,8 @@
+%%RUBY_SITEARCHLIBDIR%%/mmap.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/mmap/aa
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/mmap/b.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/mmap
+%%PORTDOCS%%%%RUBY_DOCDIR%%/mmap/README.en
+%%PORTDOCS%%%%RUBY_DOCDIR%%/mmap/mmap.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/mmap/mmap.rd
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/mmap