aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-10-11 20:41:09 +0800
committermiwi <miwi@FreeBSD.org>2009-10-11 20:41:09 +0800
commit13766670f2c96f91a5103a99ddad9f6cd4f9246b (patch)
tree108b506768c3055d014fad04b22453bae0a7c6d9 /devel
parentff8aa32850ad73d40290b648cd27e7337a326f17 (diff)
downloadfreebsd-ports-gnome-13766670f2c96f91a5103a99ddad9f6cd4f9246b.tar.gz
freebsd-ports-gnome-13766670f2c96f91a5103a99ddad9f6cd4f9246b.tar.zst
freebsd-ports-gnome-13766670f2c96f91a5103a99ddad9f6cd4f9246b.zip
This is a small ruby library that allows Ruby to 'tail' a file,
including following a file, that still is growing like the unix command 'tail -f' can. This Library is similar to Perl's File::Tail. It can be used to extend Ruby's File-objects, for File-derived classes, or by using the included simple File::Tail::Logfile class. WWW: http://file-tail.rubyforge.org/ PR: ports/139400 Submitted by: Eric Freeman <freebsdports at chillibear.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-file-tail/Makefile20
-rw-r--r--devel/rubygem-file-tail/distinfo3
-rw-r--r--devel/rubygem-file-tail/pkg-descr9
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0fa0be42ae2e..451e058870f3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2732,6 +2732,7 @@
SUBDIR += rubygem-fastercsv
SUBDIR += rubygem-fastthread
SUBDIR += rubygem-fattr
+ SUBDIR += rubygem-file-tail
SUBDIR += rubygem-gdata
SUBDIR += rubygem-gem_plugin
SUBDIR += rubygem-georuby
diff --git a/devel/rubygem-file-tail/Makefile b/devel/rubygem-file-tail/Makefile
new file mode 100644
index 000000000000..618725ba7115
--- /dev/null
+++ b/devel/rubygem-file-tail/Makefile
@@ -0,0 +1,20 @@
+# Ports collection makefile for: rubygem-file-tail
+# Date created: 06 October 2009
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= file-tail
+PORTVERSION= 1.0.4
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= This is a small Ruby library that allows Ruby to 'tail' files
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-file-tail/distinfo b/devel/rubygem-file-tail/distinfo
new file mode 100644
index 000000000000..1750a1d2ce38
--- /dev/null
+++ b/devel/rubygem-file-tail/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/file-tail-1.0.4.gem) = c44b0f8afa5f161122896e93c9de1126
+SHA256 (rubygem/file-tail-1.0.4.gem) = 7243c9aa5dffa379608403303b5ffb2909dc7e6cf1799239e591508d83f8873b
+SIZE (rubygem/file-tail-1.0.4.gem) = 18944
diff --git a/devel/rubygem-file-tail/pkg-descr b/devel/rubygem-file-tail/pkg-descr
new file mode 100644
index 000000000000..3e35bae077ab
--- /dev/null
+++ b/devel/rubygem-file-tail/pkg-descr
@@ -0,0 +1,9 @@
+This is a small ruby library that allows Ruby to 'tail' a file,
+including following a file, that still is growing like the unix
+command 'tail -f' can.
+
+This Library is similar to Perl's File::Tail. It can be used to
+extend Ruby's File-objects, for File-derived classes, or by
+using the included simple File::Tail::Logfile class.
+
+WWW: http://file-tail.rubyforge.org/