aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-06 20:30:31 +0800
committerPawel Pekala <pawel@FreeBSD.org>2014-07-06 20:30:31 +0800
commit13d1c547122df99ce8fe180a385f9531b54f7b60 (patch)
tree4ff0051007c0f365b8ff404d3a0b8ebef8cf9dc5 /devel
parent072b35fbcb37d9c7417ae3524410dcb175ae148b (diff)
downloadfreebsd-ports-gnome-13d1c547122df99ce8fe180a385f9531b54f7b60.tar.gz
freebsd-ports-gnome-13d1c547122df99ce8fe180a385f9531b54f7b60.tar.zst
freebsd-ports-gnome-13d1c547122df99ce8fe180a385f9531b54f7b60.zip
Don't hardcode gcc in xmake binary
Diffstat (limited to 'devel')
-rw-r--r--devel/xmake/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/xmake/Makefile b/devel/xmake/Makefile
index eb7a44a519a5..d822a58d1252 100644
--- a/devel/xmake/Makefile
+++ b/devel/xmake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmake
PORTVERSION= 1.06
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://apollo.backplane.com/xmake/
EXTRACT_SUFX= .tgz
@@ -16,4 +17,7 @@ PLIST_FILES= bin/xmake man/man1/xmake.1.gz
post-extract:
@${RM} -rf ${WRKSRC}/obj
+post-patch:
+ @${REINPLACE_CMD} 's|gcc|cc|' ${WRKSRC}/defs.h
+
.include <bsd.port.mk>