aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2007-10-08 19:44:34 +0800
committerbms <bms@FreeBSD.org>2007-10-08 19:44:34 +0800
commit14c301a28e0f08dd6345fff73e3f5fd0a9aef06b (patch)
tree0d0c23407b17b2fd1818f9f4b4271e92f7467e3c /devel
parent9080d02d02e0fc88b351e332ea27ef815fcd6edf (diff)
downloadfreebsd-ports-gnome-14c301a28e0f08dd6345fff73e3f5fd0a9aef06b.tar.gz
freebsd-ports-gnome-14c301a28e0f08dd6345fff73e3f5fd0a9aef06b.tar.zst
freebsd-ports-gnome-14c301a28e0f08dd6345fff73e3f5fd0a9aef06b.zip
Add symlink creation; the tool is mostly invoked via symlinks.
Diffstat (limited to 'devel')
-rw-r--r--devel/k8048/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/k8048/Makefile b/devel/k8048/Makefile
index 4ffdd8b3475d..300600e8e6c1 100644
--- a/devel/k8048/Makefile
+++ b/devel/k8048/Makefile
@@ -7,6 +7,7 @@
PORTNAME= k8048
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://dev.kewl.org/k8048/
DISTNAME= $(PORTNAME)
@@ -18,7 +19,8 @@ USE_GMAKE= yes
#BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
-PLIST_FILES= bin/${PORTNAME}
+BIN_SYMLINKS= bin/ktest bin/kdebug bin/k14 bin/k16
+PLIST_FILES= bin/${PORTNAME} ${BIN_SYMLINKS}
do-build:
cd ${BUILD_WRKSRC}/${PORTNAME} && ${GMAKE} all
@@ -26,5 +28,8 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${PORTNAME} \
${PREFIX}/bin/${PORTNAME}
+.for i in ${BIN_SYMLINKS}
+ ${LN} -s ${PREFIX}/bin/${PORTNAME} ${PREFIX}/${i}
+.endfor
.include <bsd.port.mk>